light 0.1.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 85

light #

A light sensor plugin for Flutter, reads the light intensity registered by the light sensor (in [Lux]), and reports this number back via a stream. The API for getting the light exposure is only available on Android devices, and the plugin will therefore not work for iOS devices.

Install #

Add light as a dependency in pubspec.yaml. For help on adding as a dependency, view the documentation.

Usage #

All incoming data points are streamed with a StreamSubscription which is set up by calling the listen() method on the light.lightSensorStream stream object.

Given a method _onData(int lux) the subscription can be set up as follows:

Light _light;
StreamSubscription _subscription;
...
void onData(int luxValue) async {
    print("Lux value from Light Sensor: $luxValue");
}

void startListening() {
    _light = new Light();
    try {
      _subscription = _light.lightSensorStream.listen(onData);
    }
    on LightException catch (exception) {
      print(exception);
    }
}

The stream can also be cancelled again by calling the cancel() method:

  void stopListening() {
    _subscription.cancel();
  }

0.0.1 #

  • TODO: Describe initial release.

example/README.md

light_example #

A Flutter plugin for retrieving the light sensor data using a platform channel. Works for Android only, since the light sensor API is not available on iOS.

Usage #

class MyClass {
  String _luxString = 'Unknown';
  StreamSubscription<int> _subscription;
  Light _light;
      
    // Platform messages are asynchronous, so we initialize in an async method.
    void someSetupFunction() {
      _light = new Light();
     _subscription = _light.lightSensorStream.listen(_onData,
             onError: _onError, onDone: _onDone, cancelOnError: true);
    }
    
    void _onData(int luxValue) async {
    // Do something with the luxValue
    }
    
    void _onDone() {
    // Handle finish
    }
    
    void _onError(error) {
    // Handle the error
    }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  light: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:light/light.dart';
  
Version Uploaded Documentation Archive
0.1.1 Mar 6, 2019 Go to the documentation of light 0.1.1 Download light 0.1.1 archive
0.1.0 Mar 4, 2019 Go to the documentation of light 0.1.0 Download light 0.1.0 archive
0.0.8 Mar 4, 2019 Go to the documentation of light 0.0.8 Download light 0.0.8 archive
0.0.7 Feb 23, 2019 Go to the documentation of light 0.0.7 Download light 0.0.7 archive
0.0.6 Feb 13, 2019 Go to the documentation of light 0.0.6 Download light 0.0.6 archive
0.0.5 Feb 13, 2019 Go to the documentation of light 0.0.5 Download light 0.0.5 archive
0.0.4 Nov 19, 2018 Go to the documentation of light 0.0.4 Download light 0.0.4 archive
0.0.3 Oct 4, 2018 Go to the documentation of light 0.0.3 Download light 0.0.3 archive
0.0.2 Oct 4, 2018 Go to the documentation of light 0.0.2 Download light 0.0.2 archive
0.0.1 Oct 4, 2018 Go to the documentation of light 0.0.1 Download light 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
70
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
85
Learn more about scoring.

We analyzed this package on Apr 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/light.dart.

Run flutter format to format lib/light.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8