loading_view 1.0.2

  • README.md
  • Installing
  • Versions
  • 74


A Flutter Loading View

How to Use

new LoadingView(35.0
    ,color:Colors.black, duration:const Duration(milliseconds: 600))

[1.0.0] - first release.

  • add release.

[1.0.1] - (MODIFY) add property.

  • add duration property.

[1.0.2] - (MODIFY) .

  • chang size to double.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  loading_view: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:loading_view/loading_view.dart';
Version Uploaded Documentation Archive
1.0.2 Aug 17, 2018 Go to the documentation of loading_view 1.0.2 Download loading_view 1.0.2 archive
1.0.1 Aug 17, 2018 Go to the documentation of loading_view 1.0.1 Download loading_view 1.0.1 archive
1.0.0 Aug 17, 2018 Go to the documentation of loading_view 1.0.0 Download loading_view 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use loading_view.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies