location_context 1.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 40

location_context

Build Status

Helper functions to share location data using InheritedWidgets

This plugin is also available on pub

Getting Started

For help getting started with Flutter, view our online documentation. You can also visit us at Flutter Institute

For help on editing package code, view the documentation.

[1.0.1] - 2018-07-18

  • Removing unused import from the test files

[1.0.0] - 2018-07-17

  • Initial release for sharing location data using InheritedWidget

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  location_context: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:location_context/location_context.dart';
  
Version Uploaded Documentation Archive
1.0.2 Aug 4, 2018 Go to the documentation of location_context 1.0.2 Download location_context 1.0.2 archive
1.0.1+1 Aug 3, 2018 Go to the documentation of location_context 1.0.1+1 Download location_context 1.0.1+1 archive
1.0.1 Jul 19, 2018 Go to the documentation of location_context 1.0.1 Download location_context 1.0.1 archive
1.0.0 Jul 17, 2018 Go to the documentation of location_context 1.0.0 Download location_context 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
23
Health:
Code health derived from static analysis. [more]
56
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Aug 21, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.11.8
  • Flutter: 0.5.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Issues and suggestions

Fix lib/src/context.dart.

Analysis of lib/src/context.dart failed with 2 errors:

line 73 col 37: The method 'listen' isn't defined for the class 'Function'.

line 94 col 42: A value of type '() → Future<Map<String, double>>' can't be assigned to a variable of type 'Map<String, double>'.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use location_context.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <3.0.0
flutter 0.0.0
location ^1.3.4 1.4.0
quiver ^0.29.0+1 0.29.0+2 2.0.0+1
Transitive dependencies
collection 1.14.6 1.14.11
dart2_constant 1.0.2+dart2
matcher 0.12.4
meta 1.1.5 1.1.6
path 1.6.2
sky_engine 0.0.99
stack_trace 1.9.3
typed_data 1.1.5 1.1.6
vector_math 2.0.6 2.0.8
Dev dependencies
flutter_test