lodash 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 10

Lodash

Linux Build Pub version Commitizen friendly

Utility library. Port of the JavaScript lodash library.

Installing via Pub

Add this to your package's pubspec.yaml file:

dependencies:
  lodash: 0.0.1

Usage

import "package:lodash/lodash.dart" as _;

Test

pub run test

Contributing

  1. Fork it (https://github.com/SuperPaintman/lodash.dart/fork)
  2. Create your feature branch (git checkout -b feature/<feature_name>)
  3. Commit your changes (git commit -am '<type>(<scope>): added some feature')
  4. Push to the branch (git push origin feature/<feature_name>)
  5. Create a new Pull Request

Contributors


API

Docs


Changelog

Changelog


License

MIT

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  lodash: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:lodash/lodash.dart';
  
Version Uploaded Documentation Archive
0.0.1 Jul 7, 2017 Go to the documentation of lodash 0.0.1 Download lodash 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
19
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
10
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Health issues and suggestions

Document public APIs (-10 points)

11 out of 11 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Package is getting outdated. (-41.37 points)

The package was released 73 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use lodash.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Dev dependencies
test 0.12.23+1