log 0.0.6

  • README.md
  • Installing
  • Versions
  • 28

log

A logging tool for dart CLI applications.

Output when running the demo.

alt tag

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  log: ^0.0.6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:log/log.dart';
  
Version Uploaded Documentation Archive
0.0.6 Feb 18, 2016 Go to the documentation of log 0.0.6 Download log 0.0.6 archive
0.0.5 Feb 18, 2016 Go to the documentation of log 0.0.5 Download log 0.0.5 archive
0.0.4 Feb 9, 2016 Go to the documentation of log 0.0.4 Download log 0.0.4 archive
0.0.3 Jan 26, 2016 Go to the documentation of log 0.0.3 Download log 0.0.3 archive
0.0.2 Jan 21, 2016 Go to the documentation of log 0.0.2 Download log 0.0.2 archive
0.0.1 Jan 21, 2016 Go to the documentation of log 0.0.1 Download log 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
55
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

We analyzed this package on Nov 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.12.6

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because log depends on dye any which requires SDK version >=1.8.0 <2.0.0, version solving failed.

Health suggestions

Format lib/log.dart.

Run dartfmt to format lib/log.dart.

Format lib/src/timestamp.dart.

Run dartfmt to format lib/src/timestamp.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Package is too old. (-100 points)

The package was released more than two years ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use log.dart. Packages with multiple examples should use example/readme.md.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0