log4d 1.0.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new60

log4d #

pub package GitHub stars GitHub

A dart logging tool.

Create a Server with shell.

And use dart code to create a client.

Document #

Server document

Gitbook Version

LICENSE #

the package under MIT

some copy from other library

Under MIT:

Under Apache 2.0:

1.0.4 #

fix:

  • add entity bug

1.0.3 #

fix:

  • replace : to =

1.0.2 #

format code

1.0.1 #

fix:

  • host

add:

  • force

1.0.0 #

  • Initial version, created by Stagehand

example/main.dart

void main() {}

server() {}

client() {}

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate log4d

2. Use it

The package has the following executables:


$ log4d
$ log4d_client

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  log4d: ^1.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:log4d/log4d.dart';
  
Version Uploaded Documentation Archive
1.0.4 Mar 4, 2019 Go to the documentation of log4d 1.0.4 Download log4d 1.0.4 archive
1.0.3 Mar 1, 2019 Go to the documentation of log4d 1.0.3 Download log4d 1.0.3 archive
1.0.2 Mar 1, 2019 Go to the documentation of log4d 1.0.2 Download log4d 1.0.2 archive
1.0.1 Mar 1, 2019 Go to the documentation of log4d 1.0.1 Download log4d 1.0.1 archive
1.0.0 Mar 1, 2019 Go to the documentation of log4d 1.0.0 Download log4d 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
20
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Mar 6, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms: Flutter, other

Primary library: package:log4d/log4d.dart with components: io, isolate.

Health issues and suggestions

Document public APIs. (-1 points)

47 out of 47 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
ansicolor ^1.0.2 1.0.2
args ^1.5.1 1.5.1
shelf ^0.7.4 0.7.4
shelf_web_socket ^0.2.2+4 0.2.2+4
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
http_parser 3.1.3
meta 1.1.7
path 1.6.2
source_span 1.5.5
stack_trace 1.9.3
stream_channel 1.6.8
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
web_socket_channel 1.0.9
Dev dependencies
test ^1.0.0