luce_test 0.0.5

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new31

Test package for luce apps.

Work in progress.

0.0.5

  • Upgrade to luce 0.0.11.

0.0.4

  • Introduce more linter rules.

0.0.3

  • Updates for Luce 0.0.8.

0.0.2

  • Bumped Dart SDK version to 2.1.0.

0.0.1

  • Initial import.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  luce_test: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:luce_test/luce_test.dart';
  
Version Uploaded Documentation Archive
0.0.5 Nov 28, 2018 Go to the documentation of luce_test 0.0.5 Download luce_test 0.0.5 archive
0.0.4 Nov 27, 2018 Go to the documentation of luce_test 0.0.4 Download luce_test 0.0.4 archive
0.0.3 Nov 26, 2018 Go to the documentation of luce_test 0.0.3 Download luce_test 0.0.3 archive
0.0.2 Nov 24, 2018 Go to the documentation of luce_test 0.0.2 Download luce_test 0.0.2 archive
0.0.1 Nov 24, 2018 Go to the documentation of luce_test 0.0.1 Download luce_test 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
1
Health:
Code health derived from static analysis. [more]
75
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
31
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms:

Primary library: package:luce_test/luce_test.dart with components: html, isolate.

Health issues and suggestions

Fix platform conflict in lib/luce_test.dart. (-25 points)

Make sure that the imported libraries are not in conflict. Detected components: html, isolate.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Primary library: package:luce_test/luce_test.dart with components: html, isolate.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use luce_test.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
luce ^0.0.11 0.0.13
meta ^1.1.6 1.1.6
test ^1.5.1 1.5.1+1
Transitive dependencies
analyzer 0.34.0
args 1.5.1
async 2.0.8
boolean_selector 1.0.4
charcode 1.1.2
collection 1.14.11
convert 2.0.2
crypto 2.0.6
csslib 0.14.6
front_end 0.1.7
glob 1.1.7
html 0.13.3+3
http 0.12.0
http_multi_server 2.0.5
http_parser 3.1.3
io 0.3.3
js 0.6.1+1
json_rpc_2 2.0.9
kernel 0.3.7
logging 0.11.3+2
matcher 0.12.3+1 0.12.4
mime 0.9.6+2
multi_server_socket 1.0.2
node_preamble 1.4.4
package_config 1.0.5
package_resolver 1.0.6
path 1.6.2
plugin 0.2.0+3
pool 1.3.6
pub_semver 1.4.2
shelf 0.7.3+3
shelf_packages_handler 1.0.4
shelf_static 0.2.8
shelf_web_socket 0.2.2+4
source_map_stack_trace 1.1.5
source_maps 0.10.8
source_span 1.4.1
stack_trace 1.9.3
stream_channel 1.6.8
string_scanner 1.0.4
term_glyph 1.0.1
test_api 0.2.1
test_core 0.2.0+1
typed_data 1.1.6
utf 0.9.0+5
vm_service_client 0.2.6
watcher 0.9.7+10
web_socket_channel 1.0.9
yaml 2.1.15