lunar_calendar_converter 1.0.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new56

Using

Import the library:

import 'lunar_solar_converter.dart';

You can use this converter to convert calendar from one to another between lunar calendar and solar calendar. For example:

Lunar lunar = Lunar(lunarYear: 2022, lunarMonth: 4, lunarDay: 1, isLeap: false);
Solar solar = LunarSolarConverter.lunarToSolar(lunar);
print(solar);

You will get 公元2022年5月1日.

or

Solar solar = Solar(solarYear: 2018, solarMonth: 8, solarDay: 22);
Lunar lunar = LunarSolarConverter.solarToLunar(solar);
print(lunar);

You will get 戊戌年(2018)七月十二.

1.0.3

  • Format code
  • Add examples

1.0.2

  • Optimize documents

1.0.1

  • Make some inner method private
  • Optimize documents

1.0.0

  • Initial version

example/main.dart

import './../lib/lunar_solar_converter.dart';

main(List<String> arguments) {
  Lunar lunar = Lunar(lunarYear: 2020, lunarMonth: 4, lunarDay: 4, isLeap: true);
  var result1 = LunarSolarConverter.lunarToSolar(lunar);
  var dateTime = result1.dateTime;
  print("$lunar -> $result1 / $dateTime");

  Solar solar = Solar(solarYear: 2020, solarMonth: 5, solarDay: 26);
  Lunar result2 = LunarSolarConverter.solarToLunar(solar);
  print("$solar -> $result2");
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  lunar_calendar_converter: ^1.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:lunar_calendar_converter/lunar.dart';
import 'package:lunar_calendar_converter/lunar_solar_converter.dart';
import 'package:lunar_calendar_converter/solar.dart';
  
Version Uploaded Documentation Archive
1.0.3 Aug 23, 2018 Go to the documentation of lunar_calendar_converter 1.0.3 Download lunar_calendar_converter 1.0.3 archive
1.0.2 Aug 23, 2018 Go to the documentation of lunar_calendar_converter 1.0.2 Download lunar_calendar_converter 1.0.2 archive
1.0.1 Aug 23, 2018 Go to the documentation of lunar_calendar_converter 1.0.1 Download lunar_calendar_converter 1.0.1 archive
1.0.0 Aug 22, 2018 Go to the documentation of lunar_calendar_converter 1.0.0 Download lunar_calendar_converter 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
16
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Sep 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.3

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Suggestions

The description is too long.

Search engines will display only the first part of the description. Try to keep it under 180 characters.

Format lib/lunar.dart.

Run dartfmt to format lib/lunar.dart.

Format lib/lunar_solar_converter.dart.

Run dartfmt to format lib/lunar_solar_converter.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <3.0.0