m4d_components 0.1.7

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 39

Material4Dart - Basic Components #

Basic components like MaterialButton, MaterialCheckbox and so on

Examples #

GitHub

Change Log for m4d_components #

Material Design 4 Dart - Basic components

Unreleased #

Feature #

Docs #

v0.1 - 2018-10-19

Docs #

This CHANGELOG.md was generated with Changelog for Dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  m4d_components: ^0.1.7

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:m4d_components/m4d_components.dart';
  
Version Uploaded Documentation Archive
0.1.31 Jan 17, 2019 Go to the documentation of m4d_components 0.1.31 Download m4d_components 0.1.31 archive
0.1.29 Dec 19, 2018 Go to the documentation of m4d_components 0.1.29 Download m4d_components 0.1.29 archive
0.1.26 Dec 19, 2018 Go to the documentation of m4d_components 0.1.26 Download m4d_components 0.1.26 archive
0.1.24 Dec 19, 2018 Go to the documentation of m4d_components 0.1.24 Download m4d_components 0.1.24 archive
0.1.9 Oct 23, 2018 Go to the documentation of m4d_components 0.1.9 Download m4d_components 0.1.9 archive
0.1.7 Oct 23, 2018 Go to the documentation of m4d_components 0.1.7 Download m4d_components 0.1.7 archive
0.1.3 Oct 23, 2018 Go to the documentation of m4d_components 0.1.3 Download m4d_components 0.1.3 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
58
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
51
Overall:
Weighted score of the above. [more]
39
Learn more about scoring.

We analyzed this package on Apr 4, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms:

Error(s) prevent platform classification:

Error(s) in lib/m4d_formatter.dart: Classes can only extend other classes.

Health issues and suggestions

Fix lib/components/MaterialRadio.dart. (-69.30 points)

Analysis of lib/components/MaterialRadio.dart failed with 4 errors, 6 hints, including:

line 39 col 67: Undefined class 'ioc.IOCContainer'.

line 311 col 72: Undefined class 'ioc.IOCContainer'.

line 389 col 79: Undefined class 'ioc.IOCContainer'.

line 397 col 80: Undefined class 'ioc.IOCContainer'.

line 37 col 33: Don't explicitly initialize variables to null.

Fix lib/components/MaterialDivDataTable.dart. (-68.83 points)

Analysis of lib/components/MaterialDivDataTable.dart failed with 4 errors, 3 hints, including:

line 42 col 75: Undefined class 'ioc.IOCContainer'.

line 202 col 78: Undefined class 'ioc.IOCContainer'.

line 385 col 47: Undefined class 'ioc.IOCContainer'.

line 393 col 47: Undefined class 'ioc.IOCContainer'.

line 52 col 5: Avoid return types on setters.

Fix lib/components/MaterialFormatter.dart. (-68.67 points)

Analysis of lib/components/MaterialFormatter.dart failed with 4 errors, 2 hints, including:

line 47 col 71: Undefined class 'ioc.IOCContainer'.

line 63 col 85: The function 'IOCContainer' isn't defined.

line 104 col 64: Undefined class 'ioc.IOCContainer'.

line 131 col 50: Undefined class 'ioc.IOCContainer'.

line 28 col 24: Don't explicitly initialize variables to null.

Fix additional 28 files with analysis or formatting issues. (-920.25 points)

Additional issues in the following files:

  • lib/m4d_components.dart (3 errors, 2 hints)
  • lib/m4d_formatter.dart (3 errors, 1 hint)
  • lib/components/MaterialLayout.dart (2 errors, 8 hints)
  • lib/components/MaterialCheckbox.dart (2 errors, 7 hints)
  • lib/components/MaterialSwitch.dart (2 errors, 5 hints)
  • lib/components/MaterialTextfield.dart (2 errors, 4 hints)
  • lib/components/MaterialIconToggle.dart (2 errors, 3 hints)
  • lib/components/MaterialMenu.dart (2 errors, 3 hints)
  • lib/components/MaterialProgressVertical.dart (2 errors, 3 hints)
  • lib/components/MaterialSlider.dart (2 errors, 3 hints)
  • lib/components/MaterialSpinner.dart (2 errors, 3 hints)
  • lib/components/MaterialAccordion.dart (2 errors, 2 hints)
  • lib/components/MaterialBadge.dart (2 errors, 2 hints)
  • lib/components/MaterialButton.dart (2 errors, 2 hints)
  • lib/components/MaterialLabelfield.dart (2 errors, 2 hints)
  • lib/components/MaterialProgress.dart (2 errors, 2 hints)
  • lib/components/MaterialRipple.dart (2 errors, 2 hints)
  • lib/components/MaterialTooltip.dart (2 errors, 1 hint)
  • lib/components/MaterialDataTable.dart (2 errors)
  • lib/components/MaterialTabs.dart (2 errors)
  • lib/formatter/utils/FormatterPipeline.dart (2 hints)
  • lib/formatter/ChooseFormatter.dart (1 hint)
  • lib/formatter/NumberFormatter.dart (1 hint)
  • lib/components/utils/FallbackFormatter.dart (Run dartfmt to format lib/components/utils/FallbackFormatter.dart.)
  • lib/formatter/DecoratorFormatter.dart (Run dartfmt to format lib/formatter/DecoratorFormatter.dart.)
  • lib/formatter/LowerCaseFormatter.dart (Run dartfmt to format lib/formatter/LowerCaseFormatter.dart.)
  • lib/formatter/UpperCaseFormatter.dart (Run dartfmt to format lib/formatter/UpperCaseFormatter.dart.)
  • lib/services.dart (Run dartfmt to format lib/services.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Error(s) in lib/m4d_formatter.dart: Classes can only extend other classes.

The package description is too short. (-19 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and m4d_components.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
console_log_handler ^1.0.0 1.1.6
intl ^0.15.0 0.15.8
logging >=0.11.3 <1.0.0 0.11.3+2
m4d_core >=0.1.0 <1.0.0 0.2.21
path ^1.4.0 1.6.2
platform_detect ^1.3.0 1.3.5
validate ^1.0.0 1.7.0
Transitive dependencies
analyzer 0.35.4 0.36.0
ansicolor 1.0.2
args 1.5.1
async 2.1.0
build_cli_annotations 1.1.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
dart_style 1.2.4 1.2.5
front_end 0.1.14 0.1.15
glob 1.1.7
intl_translation 0.17.3
kernel 0.3.14 0.3.15
l10n 2.0.19
meta 1.1.7
optional 3.0.1
package_config 1.0.5
petitparser 2.2.1
pub_semver 1.4.2
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+10
where 4.4.0 6.1.0+1
yaml 2.1.15
Dev dependencies
build_runner any
build_test any
build_web_compilers any
test any