m4d_flux 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 65

Material 4 Dart - Flux DataStore #

Change Log for m4d_flux #

Material Design 4 Dart - Flux-Datastore

This CHANGELOG.md was generated with Changelog for Dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  m4d_flux: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:m4d_flux/m4d_flux.dart';
  
Version Uploaded Documentation Archive
0.1.0 Nov 2, 2018 Go to the documentation of m4d_flux 0.1.0 Download m4d_flux 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
42
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:m4d_flux/m4d_flux.dart.

Health suggestions

Fix lib/flux/Emitter.dart. (-0.50 points)

Analysis of lib/flux/Emitter.dart reported 1 hint:

line 58 col 42: Use = to separate a named parameter from its default value.

Format lib/flux/ActionBusImpl.dart.

Run dartfmt to format lib/flux/ActionBusImpl.dart.

Format lib/flux/DataStore.dart.

Run dartfmt to format lib/flux/DataStore.dart.

Fix additional 5 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/flux/Dispatcher.dart (Run dartfmt to format lib/flux/Dispatcher.dart.)
  • lib/flux/action.dart (Run dartfmt to format lib/flux/action.dart.)
  • lib/flux/interfaces.dart (Run dartfmt to format lib/flux/interfaces.dart.)
  • lib/flux/mixin.dart (Run dartfmt to format lib/flux/mixin.dart.)
  • lib/m4d_flux.dart (Run dartfmt to format lib/m4d_flux.dart.)

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and m4d_flux.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
console_log_handler ^1.0.0 1.1.6
logging >=0.11.3 <1.0.0 0.11.3+2
validate ^1.0.0 1.7.0
Transitive dependencies
ansicolor 1.0.2
intl 0.15.7
path 1.6.2
Dev dependencies
build_runner any
build_test any
build_web_compilers any
test any