m4d_template 0.2.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 30

Material 4 Dart - Template Components #

Examples #

GitHub

Change Log for m4d_template #

Material Design 4 Dart - Template-based components

Unreleased #

Bugs #

  • Wrong link in inplace-edit-example to GH repo a321fcb

Docs #

  • Link to samples added in README 6cd2377

v0.2 - 2018-12-06

Feature #

  • M4DListComponent added, InplaceEdit-Example works 4ba55ed

Bugs #

  • Wrong description in HTML-Template b32dc54
  • Wrong overwrite in ToDoDataStore 53ca419

Docs #

This CHANGELOG.md was generated with Changelog for Dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  m4d_template: ^0.2.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:m4d_template/m4d_template.dart';
  
Version Uploaded Documentation Archive
0.2.9 Dec 19, 2018 Go to the documentation of m4d_template 0.2.9 Download m4d_template 0.2.9 archive
0.2.7 Dec 19, 2018 Go to the documentation of m4d_template 0.2.7 Download m4d_template 0.2.7 archive
0.2.3 Dec 6, 2018 Go to the documentation of m4d_template 0.2.3 Download m4d_template 0.2.3 archive
0.1.9 Nov 19, 2018 Go to the documentation of m4d_template 0.1.9 Download m4d_template 0.1.9 archive
0.1.6 Nov 19, 2018 Go to the documentation of m4d_template 0.1.6 Download m4d_template 0.1.6 archive
0.1.2 Nov 8, 2018 Go to the documentation of m4d_template 0.1.2 Download m4d_template 0.1.2 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
30
Learn more about scoring.

We analyzed this package on Apr 4, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms:

Error(s) prevent platform classification:

Error(s) in lib/m4d_template.dart: Classes can only extend other classes.

Health issues and suggestions

Fix lib/template/components/M4DListComponent.dart. (-44.31 points)

Analysis of lib/template/components/M4DListComponent.dart failed with 2 errors, 2 hints:

line 18 col 70: Undefined class 'ioc.IOCContainer'.

line 117 col 51: Undefined class 'ioc.IOCContainer'.

line 10 col 12: Don't explicitly initialize variables to null.

line 14 col 11: Don't explicitly initialize variables to null.

Fix lib/m4d_template.dart. (-44.03 points)

Analysis of lib/m4d_template.dart failed with 2 errors, 1 hint:

line 72 col 30: Classes can only extend other classes.

line 72 col 30: Undefined class 'ioc.IOCModule'.

line 75 col 5: Method doesn't override an inherited method.

Fix lib/template/components/MdlTemplateComponent.dart. (-25.38 points)

Analysis of lib/template/components/MdlTemplateComponent.dart failed with 1 error, 1 hint:

line 45 col 58: Undefined class 'ioc.IOCContainer'.

line 27 col 5: Prefer using /// for doc comments.

Fix additional 4 files with analysis or formatting issues. (-2.49 points)

Additional issues in the following files:

  • lib/template/modules/EventCompiler.dart (3 hints)
  • lib/template/modules/Renderer.dart (1 hint)
  • lib/template/modules/TemplateRenderer.dart (1 hint)
  • lib/template/interfaces.dart (Run dartfmt to format lib/template/interfaces.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Error(s) in lib/m4d_template.dart: Classes can only extend other classes.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and m4d_template.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-10 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
console_log_handler ^1.0.0 1.1.6
intl ^0.15.0 0.15.8
logging >=0.11.3 <1.0.0 0.11.3+2
m4d_core >=0.1.0 <1.0.0 0.2.21
m4d_directive >=0.1.0 <1.0.0 0.1.16
m4d_flux >=0.1.0 <1.0.0 0.1.0
path ^1.4.0 1.6.2
platform_detect ^1.3.0 1.3.5
validate ^1.0.0 1.7.0
Transitive dependencies
analyzer 0.35.4 0.36.0
ansicolor 1.0.2
args 1.5.1
async 2.1.0
build_cli_annotations 1.1.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
dart_style 1.2.4 1.2.5
front_end 0.1.14 0.1.15
glob 1.1.7
intl_translation 0.17.3
kernel 0.3.14 0.3.15
l10n 2.0.19
m4d_components 0.1.31
meta 1.1.7
optional 3.0.1
package_config 1.0.5
petitparser 2.2.1
pub_semver 1.4.2
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+10
where 4.4.0 6.1.0+1
yaml 2.1.15
Dev dependencies
build_runner any
build_test any
build_web_compilers any
test any