mailer 1.1.1

  • Installing
  • Versions
  • 46


Mailer is an easy to use library for composing and sending emails in Dart.

Mailer supports file attachments, HTML emails and multiple transport methods.


  • Plaintext and HTML emails
  • Unicode support
  • Attachments
  • Secure (filters and sanitizes all fields context-wise)
  • Use any SMTP server like Gmail, Live, SendGrid, Amazon SES
  • SSL/TLS support
  • Pre-configured services (Gmail, Live,, etc.). Just fill in your username and password.

Filing bug tickets

Please call printDebugInformation() from the mailer package and send the output along with your helpful explanation of what went wrong.


  • All possible SMTP authentication methods (now just LOGIN)
  • Sendmail
  • Stream attachments
  • String-based attachments


Sending an email with SMTP

In this example we send an email using a Gmail account.

import 'package:mailer/mailer.dart';

main() {
  // If you want to use an arbitrary SMTP server, go with `new SmtpOptions()`.
  // This class below is just for convenience. There are more similar classes available.
  var options = new GmailSmtpOptions()
    ..username = 'your gmail username'
    ..password = 'your gmail password'; // Note: if you have Google's "app specific passwords" enabled,
                                        // you need to use one of those here.
  // How you use and store passwords is up to you. Beware of storing passwords in plain.

  // Create our email transport.
  var emailTransport = new SmtpTransport(options);

  // Create our mail/envelope.
  var envelope = new Envelope()
    ..from = ''
    ..subject = 'Testing the Dart Mailer library 語'
    ..attachments.add(new Attachment(file: new File('path/to/file')))
    ..text = 'This is a cool email message. Whats up? 語'
    ..html = '<h1>Test</h1><p>Hey!</p>';

  // Email it.
    .then((envelope) => print('Email sent!'))
    .catchError((e) => print('Error occurred: $e'));


This library is licensed under MIT.


  • loosen crypto dependency to '>=0.9.0 <3.0.0' as suggested in the crypto changelog


  • merge crypto util fix and update example
  • upgrade unittest to test and move it to dev_dependencies
  • added OpenMailBoxSmtpOptions
  • improve address parsing and sanitization (from hoylen)
  • cleanup chunkEncodedBytes and associated test
  • update example to allow CC and BCC


  • add simple example/
  • fix pubspec to pull crypto 0.9.0

1.0.0 - Oct 4, 2015

  • initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  mailer: ^1.1.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:mailer/mailer.dart';
Version Uploaded Documentation Archive
2.1.2 Jan 9, 2019 Go to the documentation of mailer 2.1.2 Download mailer 2.1.2 archive
2.1.1 Nov 29, 2018 Go to the documentation of mailer 2.1.1 Download mailer 2.1.1 archive
2.1.0 Nov 17, 2018 Go to the documentation of mailer 2.1.0 Download mailer 2.1.0 archive
2.0.2 Oct 8, 2018 Go to the documentation of mailer 2.0.2 Download mailer 2.0.2 archive
2.0.1 Sep 24, 2018 Go to the documentation of mailer 2.0.1 Download mailer 2.0.1 archive
2.0.0 Sep 20, 2018 Go to the documentation of mailer 2.0.0 Download mailer 2.0.0 archive
1.2.3 Aug 20, 2018 Go to the documentation of mailer 1.2.3 Download mailer 1.2.3 archive
1.2.2 Aug 19, 2018 Go to the documentation of mailer 1.2.2 Download mailer 1.2.2 archive
1.2.1 Aug 17, 2018 Go to the documentation of mailer 1.2.1 Download mailer 1.2.1 archive
1.2.0 Aug 17, 2018 Go to the documentation of mailer 1.2.0 Download mailer 1.2.0 archive

All 28 versions...

Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.17.0 <2.0.0