mapd 1.1.0

  • Installing
  • Versions
  • 0

MapD driver for Dart. #

Works both on server and in browser

Basic example #

  var connector = new MapdConnectorConsole()
    ..url = 'http://localhost:9090'
    ..dbName = 'mapd'
    ..user = 'mapd'
    ..password = 'HyperInteractive';

  if (!await connector.connect()) {
    throw new Exception('Error connecting to MapD');
  var version = await connector.getVersion();
  print('Version: $version');

  var status = await connector.getServerStatus();
  print('Server status: $status');

////  Breaks with method not found
//  var memorySummary = await connector.getMemorySummary();
//  print('Memory summary: $memorySummary');

//  var memoryGPU = await connector.getMemoryGPU();
//  print('Memory GPU: $memoryGPU');

  var tables = await connector.getTables();
  print('Tables: $tables');

  var fields = await connector.getFields('flights_2008_10k');
  print('Fields for "tweets_nov_feb" table');
  for (var each in fields) {
    print('   col_name: ${each.col_name}, col_type: ${each.col_type}');

  const query = "SELECT carrier_name as key0, AVG(airtime) AS val FROM flights_2008_10k WHERE airtime IS NOT NULL GROUP BY key0 ORDER BY val DESC LIMIT 100";

  var queryResult = await connector.query(query);
  print('Query: $query');
  print('Query result:');
  for (var each in queryResult) {
    print('    $each');

  await connector.disconnect();

Changelog #

1.1.0 #

  • Thrift API updated
  • connectWithSession method added (should be used in browsers for proxied access to mapd)

1.0.0 #

  • Initial published version

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  mapd: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:mapd/binary.dart';
import 'package:mapd/browser.dart';
import 'package:mapd/common.dart';
import 'package:mapd/console.dart';
Version Uploaded Documentation Archive
1.1.0 Nov 4, 2017 Go to the documentation of mapd 1.1.0 Download mapd 1.1.0 archive
1.0.0 Oct 14, 2017 Go to the documentation of mapd 1.0.0 Download mapd 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0