mark_with_label 0.0.7

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 50

Dart Marker With Labels

This project is a library to use MarkerWithLabel for V3 from dart scripts.

See Google Maps for Dart

Usage

To use this library in your code:

  • add a dependency in your pubspec.yaml :

    dependencies:
      google_maps: ">=3.0.0 <4.0.0"
      marker_with_labels: ">0.0.1 <1.0.0"
    
  • add import in your dart code:

    import 'package:google_maps/google_maps.dart';
    import 'package:marker_with_label/marker_with_label.dart';
    
  • Include the Maps API JavaScript using a script tag before your dart script and after Google Maps API.

    <script src="https://maps.googleapis.com/maps/api/js?key=API_KEY"></script>
    <script src="<your_js_location>/markerwithlabel.js"></script>
    

A very simple example :

import 'dart:html';

import 'package:google_maps/google_maps.dart';

void main() {
  final mapOptions = new MapOptions()
    ..zoom = 8
    ..center = new LatLng(-34.397, 150.644);
  new GMap(document.getElementById("map-canvas"), mapOptions);
  
  var markerWithLabelOptions = new MarkerWithLabelOptions()
    ..labelContent = "Hello Label"
    ..map = gMap
    ..position = latLng;
  
  new MarkerWithLabel(markerWithLabelOptions);
}

Examples

Examples found at https://github.com/googlemaps/v3-utility-library/tree/master/markerwithlabel/examples in the example directory.

License

Apache 2.0

Changelog

0.0.1

  • Initial version, created by Stagehand

0.0.2

  • Fix package name, remove dart from name

0.0.3

  • Fix example dependency import

0.0.4

  • Add icon property on marker options

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mark_with_label: "^0.0.7"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mark_with_label/marker_with_label.dart';
        
Version Uploaded Documentation Archive
0.0.7 Jul 14, 2017 Go to the documentation of mark_with_label 0.0.7 Download mark_with_label 0.0.7 archive
0.0.6 Jul 14, 2017 Go to the documentation of mark_with_label 0.0.6 Download mark_with_label 0.0.6 archive
0.0.5 Jul 14, 2017 Go to the documentation of mark_with_label 0.0.5 Download mark_with_label 0.0.5 archive
0.0.4 Jul 14, 2017 Go to the documentation of mark_with_label 0.0.4 Download mark_with_label 0.0.4 archive
0.0.3 Jul 13, 2017 Go to the documentation of mark_with_label 0.0.3 Download mark_with_label 0.0.3 archive
0.0.2 Jul 13, 2017 Go to the documentation of mark_with_label 0.0.2 Download mark_with_label 0.0.2 archive
0.0.1 Jul 13, 2017 Go to the documentation of mark_with_label 0.0.1 Download mark_with_label 0.0.1 archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
50
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Suggestions

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use mark_with_label.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 hint.

    Run dartfmt to format lib/src/marker_with_label.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
google_maps >=3.0.0 <4.0.0 3.2.4
js_wrapping ^0.4.0 0.4.7
Transitive dependencies
func 1.0.0
meta 1.1.2
Dev dependencies
js_wrapping_generator ^0.4.0
test ^0.12.0