marker 0.0.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new57

marker

Marker is a Markdown renderer (printer) for Dart. It takes a list of Node objects produced by the parser and renders it back to a string.

Supported markdown flavors:

The renderer supports both inline and reference links and images.

Example

import 'dart:io';

import 'package:markdown/markdown.dart';
import 'package:marker/marker.dart';

/// Renders CHANGELOG.md with all links inline
void main() {
  final file = File('CHANGELOG.md');
  /// Contains parsed tree
  final nodes = Document().parseLines(file.readAsLinesSync());
  /// Contains markdown text
  final markdown = render(nodes);
  print(markdown);
}

Changelog

All notable changes to this project will be documented in this file.

The format is based on Keep a Changelog, and this project adheres to Semantic Versioning.

Unreleased

0.0.4

Changed

  • Minor formatting changes

0.0.3

Changed

  • Pretty much everything :)

Added

  • Changelog flavor

0.0.2

Added

  • Reference images and links

0.0.1

Added

  • Initial library version

example/example.dart

import 'dart:io';

import 'package:markdown/markdown.dart';
import 'package:marker/marker.dart';

/// Renders CHANGELOG.md with all links inline
void main() {
  final file = File('CHANGELOG.md');

  /// Contains parsed tree
  final nodes = Document().parseLines(file.readAsLinesSync());

  /// Contains markdown text
  final markdown = render(nodes);
  print(markdown);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  marker: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:marker/marker.dart';
  
Version Uploaded Documentation Archive
0.0.4 Nov 3, 2018 Go to the documentation of marker 0.0.4 Download marker 0.0.4 archive
0.0.3 Nov 3, 2018 Go to the documentation of marker 0.0.3 Download marker 0.0.3 archive
0.0.2 Oct 30, 2018 Go to the documentation of marker 0.0.2 Download marker 0.0.2 archive
0.0.1 Oct 28, 2018 Go to the documentation of marker 0.0.1 Download marker 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:marker/marker.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
markdown ^2.0.0 2.0.2
Transitive dependencies
args 1.5.1
charcode 1.1.2
Dev dependencies
test ^1.0.0