masm 1.0.0-dev+1

  • Installing
  • Versions
  • 30


Pub transformer that compiles .asm files to .exe.


I created this for use with my experiment WinDart, to have Dart files in my web directory compiled to MASM Assembly, and then assembled and linked to .exe files.


You will need MASM32 installed, and it to be installed to C:\masm32. Alternatively, you can pass an masm_path in the configuration, and ML and LINK will be run from that directory.

  masm: ^1.0.0-dev needs


This library is a transformer, and supports some options.

- windart
- masm

Supported options:

  • run (bool) - If set to true, then the executable will be run on completion.
  • run_args (List<String>) - Can be included to pass them to resulting executable.
  • ml (Map) - Options to pass to ML. Option values should be strings, or true.
  • link - Same as ml (above), but these will be passed to LINK.
  • masm_path (String) - The path to the MASM installation. Default: "C:\\masm32"


run: false
  c: true
  coff: true
  Cp: true
  LIBPATH: "C:\\masm32\\lib"

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  masm: "^1.0.0-dev+1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:masm/masm.dart';
Version Uploaded Documentation Archive
1.0.0-dev+1 Jun 29, 2016 Go to the documentation of masm 1.0.0-dev+1 Download masm 1.0.0-dev+1 archive
1.0.0-dev Jun 29, 2016 Go to the documentation of masm 1.0.0-dev Download masm 1.0.0-dev archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
98 / 100
Reflects how tidy and up-to-date the package is. [more]
2 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, other

Primary library: package:masm/masm.dart with components: io, build.


  • Maintain

    Changelog entries help clients to follow the progress in your code.

  • Package is getting outdated.

    The package was released 102 weeks ago.

  • Package is pre-release.

    Pre-release versions should be used with caution, their API may change in breaking ways.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use masm.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 3 hints.

    Run dartfmt to format lib/masm.dart.


Package Constraint Resolved Available
Direct dependencies
barback >=0.15.2 <1.0.0 0.15.2+16
merge_map >=1.0.0 <2.0.0 1.0.0
path >=1.3.9 <2.0.0 1.6.1
Transitive dependencies
async 2.0.7
charcode 1.1.1
collection 1.14.10
pool 1.3.5
source_span 1.4.0
stack_trace 1.9.2
Dev dependencies
test >=0.12.14 <1.0.0