masm 1.0.0-dev+1

  • README.md
  • Installing
  • Versions
  • 0

dart_masm

Pub transformer that compiles .asm files to .exe.

About

I created this for use with my experiment WinDart, to have Dart files in my web directory compiled to MASM Assembly, and then assembled and linked to .exe files.

Installation

You will need MASM32 installed, and it to be installed to C:\masm32. Alternatively, you can pass an masm_path in the configuration, and ML and LINK will be run from that directory.

dependencies:
  masm: ^1.0.0-dev needs

Usage

This library is a transformer, and supports some options.

transformers:
- windart
- masm

Supported options:

  • run (bool) - If set to true, then the executable will be run on completion.
  • run_args (List<String>) - Can be included to pass them to resulting executable.
  • ml (Map) - Options to pass to ML. Option values should be strings, or true.
  • link - Same as ml (above), but these will be passed to LINK.
  • masm_path (String) - The path to the MASM installation. Default: "C:\\masm32"

Defaults:

run: false
ml:
  c: true
  coff: true
  Cp: true
link:
  SUBSYTEM: CONSOLE
  LIBPATH: "C:\\masm32\\lib"

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  masm: ^1.0.0-dev+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:masm/masm.dart';
  
Version Uploaded Documentation Archive
1.0.0-dev+1 Jun 29, 2016 Go to the documentation of masm 1.0.0-dev+1 Download masm 1.0.0-dev+1 archive
1.0.0-dev Jun 29, 2016 Go to the documentation of masm 1.0.0-dev Download masm 1.0.0-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

We analyzed this package on Oct 16, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.12.4

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because masm depends on barback >=0.6.2 which requires SDK version >=0.6.2 <2.0.0 or >=2.0.0-dev.17.0 <2.0.0, version solving failed.

Health suggestions

Format lib/masm.dart.

Run dartfmt to format lib/masm.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Package is too old. (-100 points)

The package was released more than two years ago.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Add SDK constraint in pubspec.yaml. (-5 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use masm.dart.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution, their API may change in breaking ways.