Support for specifying test expectations, such as for unit tests.
The matcher library provides a third-generation assertion mechanism, drawing inspiration from Hamcrest.
For more information, see Unit Testing with Dart.
Moved a number of members to the
fail, and 'wrapAsync'.
expect is in the
unittest package, these are no longer needed.
name parameter for
isInstanceOf. This was previously
deprecated, and is no longer necessary since all language implementations now
support converting the type parameter to a string directly.
isInstanceOf. All language implementations now support converting the type parameter to a string directly.
Strings containing characters that must be represented as escape sequences.
isNotEmptymatchers and simply access the
isNotEmptyfields. This allows them to work with custom collections. See Issue 21792 and Issue 21562
printsmatcher test on dart2js.
printsmatcher that matches output a callback emits via
Refactored libraries and tests.
Fixed spelling mistake.
@deprecatedannotation on matchers due to Issue 19173
Matchers related to bad language use have been removed. These represent code structure that should rarely or never be validated in tests.
Added types to a number of method arguments.
The structure of the library and test code has been updated.
Add this to your package's pubspec.yaml file:
dependencies: matcher: ^0.12.1
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.12.4||Jul 17, 2018|
|0.12.3+1||Jul 16, 2018|
|0.12.3||Jun 14, 2018|
|0.12.2+1||May 3, 2018|
|0.12.2||Apr 12, 2018|
|0.12.1+4||Sep 20, 2017|
|0.12.1+3||Sep 5, 2017|
|0.12.1+2||Aug 30, 2017|
|0.12.1+1||May 27, 2017|
|0.12.1||May 5, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=1.0.0 <2.0.0|