material2_dart 0.4.4

  • Installing
  • Versions
  • 0

This is the Dart version of angular/material2 being ported by individual.



You may be looking for the official Material Design components for AngularDart?

Project Status

Synced with the 2.0.0-alpha.9 except gesture support and non 'available' components.

Demo app.

This is the e2e example app which includes all of the components and core functions usages.



  1. Add this to your package's pubspec.yaml file. (The example)

  2. Run pub get.

  3. Import this library as import 'package:material2_dart:material.dart'. (The example)


Your contribution is welcome. Please note that this project is nothing more than a porting work of angular/material2.

Many tests have not been ported, so it is much appreciated if you help to port them.

Features and bugs

I would not add any original features on it. If you need some new features, please consider contributing angular/material2.

If you find this Dart version's specific bugs, please file them at the issue tracker.

Testing material2_dart.

Run test server on the project root.

pub serve

Run tests on dartium.

pub run test --pub-serve=8080 -p dartium


Fix several regressions on 0.4.3.


Remove Renderer to support Angular2 2.1.0 or higher.


Relax dependent package's constraint.


Upgrade angular2 dep to ^2.0.0.


Bundle pre compiled css and source map files so that users don't need to compile this package's sass files in transformer phase.

Remove package:scissors dependency.

The e2e example has moved to the independent repository ( to be more practical working example without relative path package dependencies.


Sync with the alpha.9 only for "Available" components.

(breaking): Changed the package layout to follow the convention. import 'package:material2_dart/material.dart'; to import the all components and core functions.


Sync with the alpha.8 only for "Available" components.

  • Port Async tabs demo.
  • Port button toggle component.
  • Port Slider component.


  • Upgrade Angular to beta.21.
  • Upgrade related packages and SDK constraints.
  • Add a large number of analysis options for stricter type checking and better code style.
  • Upgrade tests for angular beta.21.
  • Also Upgrade demo.

Bug fixes.

Fix MdAnchor disabled didn't work.


All porting works have done for the current target (anuglar/material2 6/15/2016).

  • Port progress bar and its demo. (Without test code.)
  • Port progress circle and its demo. (Without test code.)
  • Port ally and its demo. (Without test code.)
  • Port overlay and its demo. (Without test code.)
  • Port portal demo.
  • Port baseline demo.
  • Relax the package version constraints.


  • Move from sass to scissors again in order to fix many build errors.
  • Move demo_app from weird web/ directory to example/ directory to follow the package convention.
  • Confirm this package does not introduce any build errors now.
  • Add prerequisites and improve usage on README.


  • Port slide toggle and its demo. (Without test code.)
  • Port radio and its demo. (Without test code.)
  • Port grid list and its demo. (Without test code.)
  • Rewrite README.


  • Port checkbox. (Without enough test code.)
  • Port input. (Without enough test code.)
  • Port checkbox demo.
  • Port input demo.
  • Port tabs demo with a bug fix. Caution: async tabs doesn't work. See issues/30.
  • Add a side nave link for issues/29.


  • Port list demo.
  • Port toolbar demo with bug fixes.
  • Port sidenav demo with its bug fixes.


  • Update existing code to original angular/material2's 497a3c1 (6/15/2016).
  • Port card demo.
  • Port icon demo with bug fixes.
  • Port tabs.


  • Fix md-card didn't work.
  • Improve demo app code with sidenav, list, toolbar, button, icon. And add complete button demo (still have some problems).
  • Instead of scissors package which requires sassc, adopt sass package for easier setup.


  • Add card.


  • Experimentally enable strong-mode.


  • Add list.


  • Add sidenav, toolbar, and icon.


  • Initial version, with MdButton and the demo app.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  material2_dart: ^0.4.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:material2_dart/material.dart';
Version Uploaded Documentation Archive
0.4.4 Dec 22, 2016 Go to the documentation of material2_dart 0.4.4 Download material2_dart 0.4.4 archive
0.4.3 Dec 14, 2016 Go to the documentation of material2_dart 0.4.3 Download material2_dart 0.4.3 archive
0.4.2 Nov 7, 2016 Go to the documentation of material2_dart 0.4.2 Download material2_dart 0.4.2 archive
0.4.1 Nov 3, 2016 Go to the documentation of material2_dart 0.4.1 Download material2_dart 0.4.1 archive
0.4.0 Oct 20, 2016 Go to the documentation of material2_dart 0.4.0 Download material2_dart 0.4.0 archive
0.3.0 Sep 28, 2016 Go to the documentation of material2_dart 0.3.0 Download material2_dart 0.3.0 archive
0.2.0 Sep 28, 2016 Go to the documentation of material2_dart 0.2.0 Download material2_dart 0.2.0 archive
0.1.1 Sep 13, 2016 Go to the documentation of material2_dart 0.1.1 Download material2_dart 0.1.1 archive
0.1.0 Jun 25, 2016 Go to the documentation of material2_dart 0.1.0 Download material2_dart 0.1.0 archive
0.0.11 Jun 23, 2016 Go to the documentation of material2_dart 0.0.11 Download material2_dart 0.0.11 archive

All 19 versions...

Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.1 <2.0.0