material_menu 2.0.1

  • README.md
  • Installing
  • Versions
  • 0

material_menu #

Material menu for Angular2.

Example

<material-menu>
  <menu-item avatar="https://avatars2.githubusercontent.com/u/9996860?v=3&s=460">
    Tobe O
  </menu-item>
  <menu-item [disabled]="true" icon="favorite">
    My Likes
  </menu-item>
  <menu-item avatar="https://www.dartlang.org/assets/logo-61576b6c2423c80422c986036ead4a7fc64c70edd7639c6171eba19e992c87d9.svg">
    Dart
  </menu-item>
  <menu-item href="http://www.example.com">
    <div class="link content">
      Link content...
    </div>
  </menu-item>
</material-menu>

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  material_menu: ^2.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:material_menu/material_menu.dart';
  
Version Uploaded Documentation Archive
2.0.1 Apr 24, 2017 Go to the documentation of material_menu 2.0.1 Download material_menu 2.0.1 archive
2.0.0 Apr 24, 2017 Go to the documentation of material_menu 2.0.0 Download material_menu 2.0.0 archive
1.0.0+1 Dec 7, 2016 Go to the documentation of material_menu 1.0.0+1 Download material_menu 1.0.0+1 archive
1.0.0 Dec 3, 2016 Go to the documentation of material_menu 1.0.0 Download material_menu 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
1
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0-beta