material_pickers 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 58

Material ColorPicker

Color picker for Flutter, based on the Google Docs color picker.

alt text

Getting Started

You can embed into your material app or use it on a Dialog like this:

Future<Color> askedToLead() async => await showDialog(
    context: context,
    child: new SimpleDialog(
      title: const Text('Select color'),
      children: <Widget>[
        new ColorPicker(
          type: MaterialType.transparency,
          onColor: (color) {
            Navigator.pop(context, color);
          },
          currentColor: startColor,
        ),
      ],
    ),
  );

For help getting started with Flutter, view our online documentation.

[0.0.1] - nov 15, 2017

  • initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  material_pickers: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:material_pickers/material_pickers.dart';
  
Version Uploaded Documentation Archive
0.0.2 Nov 22, 2017 Go to the documentation of material_pickers 0.0.2 Download material_pickers 0.0.2 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
61
Health:
Code health derived from static analysis. [more]
55
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
55
Overall:
Weighted score of the above. [more]
58
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4
  • Flutter: 0.9.5

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Fix lib/src/picker.dart. (-25.75 points)

Analysis of lib/src/picker.dart failed with 1 error, 2 hints:

line 37 col 7: Missing concrete implementation of getter 'ModalRoute.barrierLabel'.

line 25 col 12: The value of the local variable 'dx' isn't used.

line 26 col 12: The value of the local variable 'dy' isn't used.

Fix lib/src/color/dropdown.dart. (-25 points)

Analysis of lib/src/color/dropdown.dart failed with 1 error:

line 34 col 7: Missing concrete implementation of getter 'ModalRoute.barrierLabel'.

Fix lib/src/color/color_picker.dart. (-0.50 points)

Analysis of lib/src/color/color_picker.dart reported 1 hint:

line 327 col 7: This class inherits from a class marked as @immutable, and therefore should be immutable (all instance fields must be final).

Format lib/src/font/expansion.dart.

Run flutter format to format lib/src/font/expansion.dart.

Format lib/src/font/font_picker.dart.

Run flutter format to format lib/src/font/font_picker.dart.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-5 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use material_pickers.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
test ^0.12.0