An interpreter for math expressions. Supports real and complex numbers.
Note: This library is still in an early state, the test coverage is not perfect, the performance is not optimized and some features are still unimplemented.
var result = evaluate("1+sin(π/2)"); print(result); // prints "2"
Add this to your package's pubspec.yaml file:
dependencies: math_evaluator: ^0.4.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:math_evaluator/ast/complex.dart'; import 'package:math_evaluator/ast/contract/calculable.dart'; import 'package:math_evaluator/ast/contract/element.dart'; import 'package:math_evaluator/ast/contract/evaluable.dart'; import 'package:math_evaluator/ast/contract/literal.dart'; import 'package:math_evaluator/ast/contract/token.dart'; import 'package:math_evaluator/ast/degree.dart'; import 'package:math_evaluator/ast/difinition/constants.dart'; import 'package:math_evaluator/ast/difinition/functions.dart'; import 'package:math_evaluator/ast/difinition/operations.dart'; import 'package:math_evaluator/ast/func.dart'; import 'package:math_evaluator/ast/group.dart'; import 'package:math_evaluator/ast/identifier.dart'; import 'package:math_evaluator/ast/number.dart'; import 'package:math_evaluator/ast/operator.dart'; import 'package:math_evaluator/evalutaor.dart'; import 'package:math_evaluator/lex.dart'; import 'package:math_evaluator/parse.dart'; import 'package:math_evaluator/util.dart';
|0.4.0||Jun 4, 2018|
|0.3.7||Jun 4, 2018|
|0.3.6||Jun 2, 2018|
|0.3.5||May 13, 2018|
|0.3.4||May 13, 2018|
|0.3.3||May 13, 2018|
|0.3.2||May 12, 2018|
|0.3.0||May 11, 2018|
|0.2.1||May 11, 2018|
|0.2.0||May 10, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=2.0.0-dev.46.0 <2.0.0|