mctimerbutton 0.0.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new60

Screenshots


TIMERBUTTON.gif

Installation and Usage


To install this package, you need to add mctimerbutton (0.0.2 or higher) to the dependencies list of the pubspec.yaml file as follow:

dependencies:
  flutter:
    sdk: flutter

  mctimerbutton: ^0.0.3

How to use


Add the import to mctimerbutton/mctimerbutton.dart

create object

new MCTimerButton(
      callback: this.buttonOnClickSendMessage,
      sendtitle: "sender message",
      time: 99,
    )

start time

    shTimerButton.state.startTimer();

stop time

    shTimerButton.state.stopTimer();

init params

 MCTimerButton(
      {this.key,
      this.callback,
      this.sendtitle = "send message",
      this.time = 60,
      this.unit = "s"});

0.0.3

  • TODO: Update description.

0.0.2

  • TODO: Release ReadME.

0.0.1

  • TODO: Describe initial release.

example/README.md

Timer Button Example

Demonstrates how to use the mctimerbutton plugin.

Getting Started

For help getting started with Flutter, view our online documentation. TIMERBUTTON.gif

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:mctimerbutton/mctimerbutton.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  MCTimerButton shTimerButton;

  @override
  void initState() {
    shTimerButton = new MCTimerButton(
      callback: this.buttonOnClickSendMessage,
      sendtitle: "发送短信",
      time: 99,
    );
    super.initState();
  }

  void buttonOnClickSendMessage() {
    shTimerButton.state.startTimer();
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        floatingActionButton: FloatingActionButton(
          child: new Text("停止"),
          onPressed: () {
            shTimerButton.state.stopTimer();
          },
        ),
        appBar: AppBar(
          title: const Text('MCTimerButton example'),
        ),
        body: Center(
          child: new Container(
            width: 150,
            height: 50,
            child: this.shTimerButton,
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mctimerbutton: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mctimerbutton/mctimerbutton.dart';
  
Version Uploaded Documentation Archive
0.0.3 Nov 16, 2018 Go to the documentation of mctimerbutton 0.0.3 Download mctimerbutton 0.0.3 archive
0.0.2 Nov 14, 2018 Go to the documentation of mctimerbutton 0.0.2 Download mctimerbutton 0.0.2 archive
0.0.1 Nov 12, 2018 Go to the documentation of mctimerbutton 0.0.1 Download mctimerbutton 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
32
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/mctimerbutton.dart. (-0.50 points)

Analysis of lib/mctimerbutton.dart reported 1 hint:

line 6 col 7: This class inherits from a class marked as @immutable, and therefore should be immutable (all instance fields must be final).

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8