md_proc 0.10.3

  • README.md
  • Installing
  • Versions
  • 42

md_proc is dead... Welcome mdown!

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  md_proc: "^0.10.3"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:md_proc/md_proc.dart';
        
Version Uploaded Documentation Archive
0.10.3 Jan 18, 2017 Go to the documentation of md_proc 0.10.3 Download md_proc 0.10.3 archive
0.10.2+1 Jan 14, 2017 Go to the documentation of md_proc 0.10.2+1 Download md_proc 0.10.2+1 archive
0.10.2 Nov 23, 2016 Go to the documentation of md_proc 0.10.2 Download md_proc 0.10.2 archive
0.10.1 Nov 21, 2016 Go to the documentation of md_proc 0.10.1 Download md_proc 0.10.1 archive
0.10.0 Nov 20, 2016 Go to the documentation of md_proc 0.10.0 Download md_proc 0.10.0 archive
0.9.0+1 Sep 6, 2016 Go to the documentation of md_proc 0.9.0+1 Download md_proc 0.9.0+1 archive
0.9.0 Sep 5, 2016 Go to the documentation of md_proc 0.9.0 Download md_proc 0.9.0 archive
0.8.2 Jan 23, 2016 Go to the documentation of md_proc 0.8.2 Download md_proc 0.8.2 archive
0.8.1 Jan 10, 2016 Go to the documentation of md_proc 0.8.1 Download md_proc 0.8.1 archive
0.8.0 Jan 4, 2016 Go to the documentation of md_proc 0.8.0 Download md_proc 0.8.0 archive

All 28 versions...

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 16, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
3 / 100
Health:
Code health derived from static analysis. [more]
98 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
53 / 100
Overall score:
Weighted score of the above. [more]
42

Platforms

Detected platforms: unsure

Error(s) prevent platform classification.

Suggestions

  • Fix lib/generators/embed_tests_generator.dart.

    Strong-mode analysis of lib/generators/embed_tests_generator.dart failed with the following error:

    line: 6 col: 8
    Target of URI doesn't exist: 'package:analyzer/dart/element/element.dart'.

  • Fix lib/generators/entities_generator.dart.

    Strong-mode analysis of lib/generators/entities_generator.dart failed with the following error:

    line: 7 col: 8
    Target of URI doesn't exist: 'package:analyzer/dart/element/element.dart'.

  • Fix platform conflicts.

    Make sure none of the libraries use mutually exclusive dependendencies.

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 2 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use md_proc.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.18.0 <2.0.0
collection >=1.9.0 <2.0.0 1.14.5
quiver ^0.24.0 0.24.0 0.28.0
Transitive dependencies
matcher 0.12.1+4
path 1.5.1
stack_trace 1.9.2
Dev dependencies
benchmark_harness 1.0.4
build_runner ^0.1.1
coverage ^0.8.0+2
markdown any
source_gen >=0.5.2 <0.6.0
test ^0.12.17+2