md_to_html 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 29

md_to_html

This is a simple transformer that converts all Markdown files into HTML based on a provided template.

To use, add md_to_html to your pubspec:

dependencies:
    md_to_html: ">=0.1.0 <0.2.0"

Then, add the transformer and set the template property to the location of a Mustache-style template:

transformers:
    md_to_html:
        template: "web/template.html"

In the template, the {{content}} tag will be replaced with the generated HTML from your Markdown. You can fill other tags by adding JSON to the beginning of your Markdown file.

For example:

{"title": "My Title"}

## This is a header

This is a paragraph.

With a template:

<html>
<head><title>{{title}}</title></head>
<body>{{content}}</body>
</html>

Would render as:

<html>
<head><title>My Title</title></head>
<body><h2>This is a header</h2>
<p>This is a paragraph.</p></body>
</html>

0.1.0

  • First release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  md_to_html: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:md_to_html/md_to_html.dart';
  
Version Uploaded Documentation Archive
0.1.0 Feb 13, 2015 Go to the documentation of md_to_html 0.1.0 Download md_to_html 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
29
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because md_to_html depends on mustache_no_mirror any which requires SDK version >=0.8.10+6 <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Add SDK constraint in pubspec.yaml.

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Package is too old.

The package was released more than two years ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use md_to_html.dart.

Format lib/md_to_html.dart.

Run dartfmt to format lib/md_to_html.dart.