mdv 0.8.5

  • Installing
  • Versions
  • 0

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mdv: ^0.8.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mdv/mdv.dart';
  
Version Uploaded Documentation Archive
0.8.5 Oct 21, 2013 Go to the documentation of mdv 0.8.5 Download mdv 0.8.5 archive
0.8.4 Oct 19, 2013 Go to the documentation of mdv 0.8.4 Download mdv 0.8.4 archive
0.8.3 Oct 17, 2013 Go to the documentation of mdv 0.8.3 Download mdv 0.8.3 archive
0.8.2 Oct 14, 2013 Go to the documentation of mdv 0.8.2 Download mdv 0.8.2 archive
0.8.1 Oct 4, 2013 Go to the documentation of mdv 0.8.1 Download mdv 0.8.1 archive
0.8.0 Oct 3, 2013 Go to the documentation of mdv 0.8.0 Download mdv 0.8.0 archive
0.7.6+4 Oct 1, 2013 Go to the documentation of mdv 0.7.6+4 Download mdv 0.7.6+4 archive
0.7.6 Sep 27, 2013 Go to the documentation of mdv 0.7.6 Download mdv 0.7.6 archive
0.7.5 Sep 21, 2013 Go to the documentation of mdv 0.7.5 Download mdv 0.7.5 archive
0.7.4 Sep 18, 2013 Go to the documentation of mdv 0.7.4 Download mdv 0.7.4 archive

All 33 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

We analyzed this package on Dec 9, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 
 Because mdv depends on observe any which requires SDK version >=0.6.2 <2.0.0, version solving failed.

Health suggestions

Format lib/mdv.dart.

Run dartfmt to format lib/mdv.dart.

Format lib/src/input_bindings.dart.

Run dartfmt to format lib/src/input_bindings.dart.

Format lib/src/list_diff.dart.

Run dartfmt to format lib/src/list_diff.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/node.dart (Run dartfmt to format lib/src/node.dart.)
  • lib/src/template.dart (Run dartfmt to format lib/src/template.dart.)
  • lib/src/template_iterator.dart (Run dartfmt to format lib/src/template_iterator.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Package is too old. (-100 points)

The package was released more than two years ago.

Maintain README.md. (-30 points)

Readme should inform others about your project, what it does, and how they can use it.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Homepage is not helpful. (-10 points)

Update the homepage property: create a website about the package or use the source repository URL.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use mdv.dart.

The description is too long. (-10 points)

Search engines will display only the first part of the description. Try to keep it under 180 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=0.8.5