mdv_observe 0.6.1

  • Installing
  • Versions
  • 0

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mdv_observe: "^0.6.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mdv_observe/mdv_observe.dart';
        
Version Uploaded Documentation Archive
0.6.1 Jun 27, 2013 Go to the documentation of mdv_observe 0.6.1 Download mdv_observe 0.6.1 archive
0.5.20 Jun 17, 2013 Go to the documentation of mdv_observe 0.5.20 Download mdv_observe 0.5.20 archive
0.5.17 Jun 12, 2013 Go to the documentation of mdv_observe 0.5.17 Download mdv_observe 0.5.17 archive
0.5.16 Jun 10, 2013 Go to the documentation of mdv_observe 0.5.16 Download mdv_observe 0.5.16 archive
0.5.15 Jun 7, 2013 Go to the documentation of mdv_observe 0.5.15 Download mdv_observe 0.5.15 archive
0.5.14+3 Jun 6, 2013 Go to the documentation of mdv_observe 0.5.14+3 Download mdv_observe 0.5.14+3 archive
0.5.14+1 Jun 5, 2013 Go to the documentation of mdv_observe 0.5.14+1 Download mdv_observe 0.5.14+1 archive
0.5.13 Jun 3, 2013 Go to the documentation of mdv_observe 0.5.13 Download mdv_observe 0.5.13 archive
0.5.12 May 29, 2013 Go to the documentation of mdv_observe 0.5.12 Download mdv_observe 0.5.12 archive
0.5.11+1 May 29, 2013 Go to the documentation of mdv_observe 0.5.11+1 Download mdv_observe 0.5.11+1 archive

All 12 versions...

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 16, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
0 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
0

Platforms

Detected platforms: unsure

Error(s) prevent platform classification.

Suggestions

  • Fix lib/src/observable_list.dart.

    Strong-mode analysis of lib/src/observable_list.dart failed with the following error:

    line: 13 col: 7
    Inconsistent declarations of 'firstWhere' are inherited from ((dynamic) → bool, {orElse: () → dynamic}) → dynamic, ((E) → bool, {orElse: () → E}) → E.

  • Fix lib/src/observable_box.dart.

    Strong-mode analysis of lib/src/observable_box.dart failed with the following error:

    line: 15 col: 32
    Classes can only extend other classes.

  • Fix further 2 Dart files.

    Similar analysis of the following files failed:

    • lib/src/observable_map.dart
    • lib/mdv_observe.dart
  • Fix platform conflicts.

    Make sure none of the libraries use mutually exclusive dependendencies.

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 3 error(s) and 0 warning(s).

  • Maintain README.md.

    Readme should inform others about your project, what it does, and how they can use it.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • The description is too long.

    Search engines will display only the first part of the description. Try to keep it under 180 characters.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use mdv_observe.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=0.6.1
Dev dependencies
unittest any