message_builder 0.1.3+5

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 45

message_builder

Generate serializable Dart classes from a schema

0.1.3+5

  • Allow build versions <2.0.0.

0.1.3+4

  • Use the 2.0 stable SDK.

0.1.3+3

  • Cast to Iterable before calling map when parsing from json to get a correct reified list type.
  • Switch to Map.map instead of new Map.fromIterable.
  • Cast primitive typed List and Map instances to a corrected reified type.

0.1.3+2

  • Allow package:build_config version 0.3.x.

0.1.3+1

  • Allow package:build version 0.12.x.

0.1.3

  • Upgrade to code_builder version 3.0
  • Add default for generate_for to avoid applying to pubspec.yaml by default.

0.1.2

  • Handle keys explicitly set to null as if they were missing.

0.1.1

  • Add a build.yaml so this builder can be used with build_runner v0.7.0

0.1.0

  • Initial version. Extracted from dart_language_server
  • Refactor to use code_builder.
  • Add support for Map type fields.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  message_builder: ^0.1.3+5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:message_builder/message_builder.dart';
  
Version Uploaded Documentation Archive
0.1.3+5 Nov 5, 2018 Go to the documentation of message_builder 0.1.3+5 Download message_builder 0.1.3+5 archive
0.1.3+4 Aug 7, 2018 Go to the documentation of message_builder 0.1.3+4 Download message_builder 0.1.3+4 archive
0.1.3+3 Jun 26, 2018 Go to the documentation of message_builder 0.1.3+3 Download message_builder 0.1.3+3 archive
0.1.3+2 Jun 22, 2018 Go to the documentation of message_builder 0.1.3+2 Download message_builder 0.1.3+2 archive
0.1.3+1 Jan 21, 2018 Go to the documentation of message_builder 0.1.3+1 Download message_builder 0.1.3+1 archive
0.1.3 Jan 13, 2018 Go to the documentation of message_builder 0.1.3 Download message_builder 0.1.3 archive
0.1.2 Jan 10, 2018 Go to the documentation of message_builder 0.1.2 Download message_builder 0.1.2 archive
0.1.1 Dec 22, 2017 Go to the documentation of message_builder 0.1.1 Download message_builder 0.1.1 archive
0.1.0 Dec 11, 2017 Go to the documentation of message_builder 0.1.0 Download message_builder 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
2
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, other

Primary library: package:message_builder/message_builder.dart with components: io, build.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use message_builder.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
build >=0.11.0 <2.0.0 1.0.1
build_config >=0.2.1 <0.4.0 0.3.1+4
code_builder ^3.1.1 3.1.3
dart_style ^1.0.0 1.2.0 1.2.1
yaml ^2.1.0 2.1.15
Transitive dependencies
analyzer 0.33.6 0.34.0
args 1.5.1
async 2.0.8
built_collection 4.1.0
built_value 6.1.6
charcode 1.1.2
collection 1.14.11
convert 2.0.2
crypto 2.0.6
csslib 0.14.6
fixnum 0.10.9
front_end 0.1.6+8 0.1.7
glob 1.1.7
html 0.13.3+3
json_annotation 2.0.0
kernel 0.3.6+8 0.3.7
logging 0.11.3+2
matcher 0.12.4
meta 1.1.6
package_config 1.0.5
plugin 0.2.0+3
pub_semver 1.4.2
pubspec_parse 0.1.2+3
quiver 2.0.1
source_span 1.4.1
stack_trace 1.9.3
string_scanner 1.0.4
typed_data 1.1.6
utf 0.9.0+5
watcher 0.9.7+10
Dev dependencies
build_runner ^1.0.0
build_test >=0.9.0 <0.11.0
path ^1.5.0 1.6.2
test ^1.0.0