message_bus 0.0.4

  • Installing
  • Versions
  • 24


A simple message_bus library for Dart


A simple usage example:

import 'package:message_bus/message_bus.dart';

MessageBus mBus = new MessageBus();

class Subscriber() extends EventHandler<String> {
    handleEvent(String event) {
        print('I got an event: $event');

main() {
    Subscriber subscriber = new Subscriber();
    mBus.subscribe(String, subscriber);
    mBus.publish('Subscriber will get this');

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Initial version


  • Add enrich functionality

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  message_bus: "^0.0.4"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:message_bus/message_bus.dart';
Version Uploaded Documentation Archive
0.0.4 Jun 18, 2016 Go to the documentation of message_bus 0.0.4 Download message_bus 0.0.4 archive
0.0.3 Jun 18, 2016 Go to the documentation of message_bus 0.0.3 Download message_bus 0.0.3 archive
0.0.2 Jun 18, 2016 Go to the documentation of message_bus 0.0.2 Download message_bus 0.0.2 archive
0.0.1 Jun 18, 2016 Go to the documentation of message_bus 0.0.1 Download message_bus 0.0.1 archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
81 / 100
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:message_bus/message_bus.dart.


  • Package is too old.

    The package was released more than two years ago.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error 6 hints.

    Strong-mode analysis of lib/src/message_bus_impl.dart failed with the following error:

    line: 24 col: 2
    Invalid override. The type of 'MessageBusImpl.undeliverableHandler=' ('(Function) → void') isn't a subtype of 'MessageBus.undeliverableHandler=' ('(dynamic) → void').

    Run dartfmt to format lib/message_bus.dart.

    Similar analysis of the following files failed:

    • lib/src/message_bus_api.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
Dev dependencies
test >=0.12.0 <0.13.0