message_bus 0.0.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

message_bus

A simple message_bus library for Dart

Usage

A simple usage example:

import 'package:message_bus/message_bus.dart';

MessageBus mBus = new MessageBus();

class Subscriber() extends EventHandler<String> {
    @override
    handleEvent(String event) {
        print('I got an event: $event');
    }
}

main() {
    Subscriber subscriber = new Subscriber();
    mBus.subscribe(String, subscriber);
    mBus.publish('Subscriber will get this');
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version

0.0.3

  • Add enrich functionality

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  message_bus: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:message_bus/message_bus.dart';
  
Version Uploaded Documentation Archive
0.0.4 Jun 18, 2016 Go to the documentation of message_bus 0.0.4 Download message_bus 0.0.4 archive
0.0.3 Jun 18, 2016 Go to the documentation of message_bus 0.0.3 Download message_bus 0.0.3 archive
0.0.2 Jun 18, 2016 Go to the documentation of message_bus 0.0.2 Download message_bus 0.0.2 archive
0.0.1 Jun 18, 2016 Go to the documentation of message_bus 0.0.1 Download message_bus 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0