metatest 0.2.2+4

  • CHANGELOG.md
  • Installing
  • Versions
  • 47

0.2.2+4

  • Compatibility with the latest test.

0.2.2+3

  • Compatibility with the latest test.

0.2.2+2

  • Compatibility with the latest test.

0.2.2+1

  • Require test version 0.12.5.

0.2.1

  • Support passing named arguments through to the underlying call to test().

0.2.0+1

  • Compatibility with the latest test.

0.2.0

  • Full compatibility with test 0.12.0.

  • Tests are no longer run in their own isolates. Instead, each test's environment is isolated manually using the test package's infrastructure.

  • initMetatest is no longer necessary and has been removed.

  • metaSetUp has been removed; the test package's setUp may be used instead.

  • expectTestResults has been removed.

0.1.1

  • Changed maximum version of unittest to support development.

0.1.0

  • First release.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  metatest: "^0.2.2+4"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:metatest/metatest.dart';
        
Version Uploaded Documentation Archive
0.2.2+4 Jan 8, 2018 Go to the documentation of metatest 0.2.2+4 Download metatest 0.2.2+4 archive
0.2.2+3 Nov 30, 2016 Go to the documentation of metatest 0.2.2+3 Download metatest 0.2.2+3 archive
0.2.2+2 May 4, 2016 Go to the documentation of metatest 0.2.2+2 Download metatest 0.2.2+2 archive
0.2.2+1 Oct 9, 2015 Go to the documentation of metatest 0.2.2+1 Download metatest 0.2.2+1 archive
0.2.2 Aug 26, 2015 Go to the documentation of metatest 0.2.2 Download metatest 0.2.2 archive
0.2.1 Jul 22, 2015 Go to the documentation of metatest 0.2.1 Download metatest 0.2.1 archive
0.2.0+1 Jul 20, 2015 Go to the documentation of metatest 0.2.0+1 Download metatest 0.2.0+1 archive
0.2.0 Jun 3, 2015 Go to the documentation of metatest 0.2.0 Download metatest 0.2.0 archive
0.1.1 Jan 27, 2015 Go to the documentation of metatest 0.1.1 Download metatest 0.1.1 archive
0.1.0 Sep 18, 2014 Go to the documentation of metatest 0.1.0 Download metatest 0.1.0 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 15, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
11 / 100
Health:
Code health derived from static analysis. [more]
79 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90 / 100
Overall score:
Weighted score of the above. [more]
47

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:metatest/metatest.dart.

Suggestions

  • Fix lib/metatest.dart.

    Strong-mode analysis of lib/metatest.dart failed with the following error:

    line: 84 col: 14
    The argument type 'Set<LiveTest>' can't be assigned to the parameter type 'List<LiveTest>'.

  • Maintain README.md.

    Readme should inform others about your project, what it does, and how they can use it.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 1 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use metatest.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
test ^0.12.30 0.12.30+3
Transitive dependencies
analyzer 0.31.1 0.31.2-alpha.0
args 1.3.0
async 2.0.3 2.0.4
barback 0.15.2+14
boolean_selector 1.0.2
charcode 1.1.1
cli_util 0.1.2+1
collection 1.14.5
convert 2.0.1
crypto 2.0.2+1
csslib 0.14.1
front_end 0.1.0-alpha.9 0.1.0-alpha.10
glob 1.1.5
html 0.13.2+2
http 0.11.3+16
http_multi_server 2.0.4
http_parser 3.1.1
io 0.3.2+1
isolate 1.1.0
js 0.6.1
kernel 0.3.0-alpha.9 0.3.0-alpha.10
logging 0.11.3+1
matcher 0.12.1+4
meta 1.1.2
mime 0.9.6
multi_server_socket 1.0.1
node_preamble 1.4.0
package_config 1.0.3
package_resolver 1.0.2
path 1.5.1
plugin 0.2.0+2
pool 1.3.4
pub_semver 1.3.2
shelf 0.7.2
shelf_packages_handler 1.0.3
shelf_static 0.2.7
shelf_web_socket 0.2.2
source_map_stack_trace 1.1.4
source_maps 0.10.4
source_span 1.4.0
stack_trace 1.9.2
stream_channel 1.6.3
string_scanner 1.0.2
term_glyph 1.0.0
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+7
web_socket_channel 1.0.6 1.0.7
yaml 2.1.13