This package builds on the work from Pedantic but tailored to my own needs.
The currently enabled lints can be found in the sample analysis_options.yaml.
To use those lints you can add a dependency in your
dev_dependencies: mfsao: "0.1.0"
and add an include in your
Please file feature requests and bugs at the issue tracker.
Add this to your package's pubspec.yaml file:
dependencies: mfsao: ^0.1.3
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.3||Feb 27, 2019|
|0.1.2||Feb 27, 2019|
|0.1.1||Feb 27, 2019|
|0.1.0||Feb 26, 2019|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Mar 6, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter, web, other
No platform restriction found in primary library
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
mfsao.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=2.1.0 <3.0.0|