midiparser 1.1.1

  • README.md
  • Installing
  • Versions
  • 0

Midiparser

This is a midiparser written dart.

Credit for the original methods and bit-shifting goes to Afandian, and his go-midi library

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate midiparser

2. Use it

The package has the following executables:


$ midiparser

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  midiparser: ^1.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:midiparser/midiparser.dart';
  
Version Uploaded Documentation Archive
1.1.1 Jan 15, 2017 Go to the documentation of midiparser 1.1.1 Download midiparser 1.1.1 archive
1.1.0 Jan 15, 2017 Go to the documentation of midiparser 1.1.0 Download midiparser 1.1.0 archive
1.0.3 Dec 11, 2016 Go to the documentation of midiparser 1.0.3 Download midiparser 1.0.3 archive
1.0.2 Dec 11, 2016 Go to the documentation of midiparser 1.0.2 Download midiparser 1.0.2 archive
1.0.1 Dec 11, 2016 Go to the documentation of midiparser 1.0.1 Download midiparser 1.0.1 archive
1.0.0 Dec 10, 2016 Go to the documentation of midiparser 1.0.0 Download midiparser 1.0.0 archive
0.1.1 Nov 24, 2016 Go to the documentation of midiparser 0.1.1 Download midiparser 0.1.1 archive
0.1.0 Nov 24, 2016 Go to the documentation of midiparser 0.1.0 Download midiparser 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Health issues and suggestions

Fix lib/src/parse.dart. (-26.12 points)

Analysis of lib/src/parse.dart failed with 1 error, 3 hints:

line 85 col 14: Undefined name 'ASCII'.

line 1 col 8: Unused import: 'dart:convert'.

line 97 col 7: The value of the local variable 'headerType' isn't used.

line 129 col 7: Equality operator == invocation with references of unrelated types.

Fix lib/src/file.dart. (-1.99 points)

Analysis of lib/src/file.dart reported 4 hints:

line 1 col 8: Unused import: 'events.dart'.

line 2 col 8: Unused import: 'midi.dart'.

line 3 col 8: Unused import: 'parse.dart'.

line 4 col 8: Unused import: 'notes.dart'.

Fix lib/src/events.dart. (-1.49 points)

Analysis of lib/src/events.dart reported 3 hints:

line 71 col 9: The value of the local variable 'length' isn't used.

line 117 col 3: This function has a return type of 'int', but doesn't end with a return statement.

line 118 col 9: The value of the local variable 'rval' isn't used.

Fix additional 3 files with analysis or formatting issues. (-0.50 points)

Additional issues in the following files:

  • bin/cli.dart (1 hint)
  • lib/src/midi.dart (Run dartfmt to format lib/src/midi.dart.)
  • lib/src/notes.dart (Run dartfmt to format lib/src/notes.dart.)

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-88.77 points)

The package was released 98 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use midiparser.dart.