mmkv_plugin 0.0.12

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new65

mmkv

Tencent MMKV Flutter wrapper

Getting Started

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.0.12

Bug Fixes

  • fix a type casting issue

0.0.11

Bug Fixes

  • fix grammar issue

0.0.10

Bug Fixes

  • fix a NPE under android

0.0.9

Bug Fixes

  • fix a crush issue under android

0.0.8

Bug Fixes

  • change main file name to be mmkv_plugin.dart which follow dart suggestion.

0.0.7

Features

  • add removeKeys

0.0.6

Features

  • dynamic put value

0.0.1

  • TODO: Describe initial release.

example/README.md

mmkv_example

Demonstrates how to use the mmkv plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mmkv_plugin: ^0.0.12

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mmkv_plugin/mmkv_plugin.dart';
  
Version Uploaded Documentation Archive
0.0.12 Nov 4, 2018 Go to the documentation of mmkv_plugin 0.0.12 Download mmkv_plugin 0.0.12 archive
0.0.11 Nov 4, 2018 Go to the documentation of mmkv_plugin 0.0.11 Download mmkv_plugin 0.0.11 archive
0.0.10 Nov 4, 2018 Go to the documentation of mmkv_plugin 0.0.10 Download mmkv_plugin 0.0.10 archive
0.0.9 Nov 4, 2018 Go to the documentation of mmkv_plugin 0.0.9 Download mmkv_plugin 0.0.9 archive
0.0.8 Nov 3, 2018 Go to the documentation of mmkv_plugin 0.0.8 Download mmkv_plugin 0.0.8 archive
0.0.7 Nov 3, 2018 Go to the documentation of mmkv_plugin 0.0.7 Download mmkv_plugin 0.0.7 archive
0.0.6 Oct 30, 2018 Go to the documentation of mmkv_plugin 0.0.6 Download mmkv_plugin 0.0.6 archive
0.0.5 Oct 20, 2018 Go to the documentation of mmkv_plugin 0.0.5 Download mmkv_plugin 0.0.5 archive
0.0.4 Oct 20, 2018 Go to the documentation of mmkv_plugin 0.0.4 Download mmkv_plugin 0.0.4 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
42
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6
  • Flutter: 0.11.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8