mock 0.12.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 8

This library is deprecated.

We recommend you look at mockito.

0.12.0

  • Moved to support latest matcher and test packages.

0.11.0+4

  • Support latest 0.11.x release of unittest which embeds matcher.

0.11.0+3

  • Use the identity of of CallMatcher to match Behavior instances, instead of toString.

0.11.0+2

  • Updated documentation link.

0.11.0+1

  • Updated unittest dependency.

0.11.0

  • Removed deprecated sharedLog

  • Improved support for calling arbitrary methods via a proxy

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mock: ^0.12.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mock/mock.dart';
  
Version Uploaded Documentation Archive
0.12.0 May 14, 2015 Go to the documentation of mock 0.12.0 Download mock 0.12.0 archive
0.11.0+4 May 14, 2015 Go to the documentation of mock 0.11.0+4 Download mock 0.11.0+4 archive
0.11.0+3 Apr 29, 2015 Go to the documentation of mock 0.11.0+3 Download mock 0.11.0+3 archive
0.11.0+2 Jul 23, 2014 Go to the documentation of mock 0.11.0+2 Download mock 0.11.0+2 archive
0.11.0+1 May 14, 2014 Go to the documentation of mock 0.11.0+1 Download mock 0.11.0+1 archive
0.10.0+1 Apr 9, 2014 Go to the documentation of mock 0.10.0+1 Download mock 0.10.0+1 archive
0.10.0 Mar 24, 2014 Go to the documentation of mock 0.10.0 Download mock 0.10.0 archive
0.12.0-beta.0 Apr 29, 2015 Go to the documentation of mock 0.12.0-beta.0 Download mock 0.12.0-beta.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
15
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
8
Learn more about scoring.

This package is not analyzed, because it is discontinued.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0