modern_charts_angular_wrapper 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 45

A web app that uses AngularDart Components

Generated by Stagehand. Used by: Get Started with Dart for the web. See LICENSE.

Changelog

0.0.1

  • Initial version, created by Stagehand

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  modern_charts_angular_wrapper: "^0.0.3"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:modern_charts_angular_wrapper/modern_charts_angular_wrapper.dart';
        
Version Uploaded Documentation Archive
0.0.3 Aug 22, 2017 Go to the documentation of modern_charts_angular_wrapper 0.0.3 Download modern_charts_angular_wrapper 0.0.3 archive
0.0.2 Aug 22, 2017 Go to the documentation of modern_charts_angular_wrapper 0.0.2 Download modern_charts_angular_wrapper 0.0.2 archive
0.0.1 Aug 21, 2017 Go to the documentation of modern_charts_angular_wrapper 0.0.1 Download modern_charts_angular_wrapper 0.0.1 archive

Analysis

We analyzed this package on Apr 9, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.46.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
84 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
45
Learn more about scoring.

Platforms

Detected platforms: web

Primary library: package:modern_charts_angular_wrapper/modern_charts_angular_wrapper.dart with components: html.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 7 hints.

    Run dartfmt to format lib/modern_charts_angular_wrapper.dart.

    Run dartfmt to format lib/src/components/linechart_component/linechart_component.dart.

    Similar analysis of the following files failed:

    • lib/src/components/piechart_component/piechart_component.dart (hint)
  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use modern_charts_angular_wrapper.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0
angular2 ^3.1.0 3.1.0+1
modern_charts ^0.1.10 0.1.12
Transitive dependencies
analyzer 0.30.0+4 0.31.1
args 0.13.7 1.4.1
async 2.0.6
barback 0.15.2+15
build 0.9.3 0.12.1
build_barback 0.2.2 0.5.0+3
charcode 1.1.1
cli_util 0.1.2+1
code_builder 1.0.4 3.0.3
code_transformers 0.5.1+4
collection 1.14.9
convert 2.0.1
crypto 2.0.2+1
csslib 0.13.7+1 0.14.1
dart_style 1.0.9+1 1.0.10
fixnum 0.10.7
front_end 0.1.0-alpha.4.1 0.1.0-alpha.11
func 1.0.0
glob 1.1.5
html 0.13.3
intl 0.15.4
isolate 1.1.0 2.0.0
js 0.6.1
kernel 0.3.0-alpha.1.1 0.3.0-alpha.11
logging 0.11.3+1
matcher 0.12.1+4
meta 1.1.2
package_config 1.0.3
path 1.5.1
plugin 0.2.0+2
pool 1.3.4
protobuf 0.5.5 0.7.2
quiver 0.25.0 0.29.0+1
source_gen 0.5.10+1 0.8.0
source_maps 0.10.4
source_span 1.4.0
stack_trace 1.9.2
string_scanner 1.0.2
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+7
yaml 2.1.13
Dev dependencies
browser ^0.10.0