mojo_sdk 0.2.32

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

mojo_sdk

This is a meta-package for the Mojo Dart SDK. This package depends on specific versions of Mojo Dart SDK leaf packages which are compatible with each other.

Your project should depend on a fixed version of this package and not on any of the Mojo Dart SDK leaf packages.

Depending on mojo_sdk

Add the following to your pubspec.yaml:

dependencies:
  mojo_sdk: 0.1.0

Always use an exact version of the mojo_sdk package when expressing your dependency

0.2.32

MOJO_SDK: 8ba175ad40bd1ee59eefdc20f1f1f1a58454b63b

0.2.31

MOJO_SDK: ccb24a5eb09f361f9b8274d344667c81ab280da7

0.2.30

MOJO_SDK: e902fed4ddf5f2d9946fa0cf4f177b0a5176ca93

0.2.29

MOJO_SDK: db036b199725a51710b2628a40151f61c3ebbb7e

0.2.28

MOJO_SDK: 38f0fb14f31edc51e94593c1915209bcc63d3c9c

0.2.27

MOJO_SDK: 24614f9961413d4527a5b1bc525102380f825705

0.2.26

MOJO_SDK: 107bac064ffded510eb8a893f5beb3faa4b7324a

0.2.25

MOJO_SDK: 12d71ee39a0af5940e1ec6807702bd05e2f3c236

0.2.24

MOJO_SDK: e95b5dbca09e6c189ca497e41a6a01b20b536f14

0.2.23

MOJO_SDK: 2f662f419ff3328ee1d1a1a47e2a0056b80a2086

0.2.22

MOJO_SDK: d3a630fd6b85c5fdbb944d748827e79e962eb012

0.2.21

MOJO_SDK: b013d061e7904f5e8a26fe94e64481b01444886d

0.2.20

MOJO_SDK: 68bf04748a69d8702e8f888f711082feee690011

0.2.19

MOJO_SDK: 335418d40d1cc46f14b43d37c4b7a0a5b7777689

0.2.18

MOJO_SDK: f59d61349e6c690320e56314687782fc1817f9a1

0.2.17

MOJO_SDK: 1f8e74c594bf1e638d026b6ad12b83d2f1fd8bc9

0.2.16

MOJO_SDK: 2829804fb7dce2fe603e430913b948e819c811b0

0.2.15

MOJO_SDK: 9ec7563706bc9a57cc0b645c93433fc9139c80e5

0.2.14

MOJO_SDK: f64c6d64858915d32f185ee6fc7b438b46ca3738

0.2.13

MOJO_SDK: ecb64e7a16dca8374350e5b329694de85a7a1476

0.2.12

MOJO_SDK: 147dc026d9a6aca871d35875d0fd51fc19c3dc93

0.2.11

MOJO_SDK: 56bf5b4c1fe3657dde809878257a83865ba84815

0.2.10

MOJO_SDK: 683c4ed82364dd30f6de501dffcf058264d01e80

0.2.9

0.2.8

0.2.7

0.2.6

0.2.5

0.2.4

0.2.3

0.1.0

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mojo_sdk: ^0.2.32

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.2.32 Aug 17, 2016 Go to the documentation of mojo_sdk 0.2.32 Download mojo_sdk 0.2.32 archive
0.2.31 Jul 1, 2016 Go to the documentation of mojo_sdk 0.2.31 Download mojo_sdk 0.2.31 archive
0.2.30 Jun 28, 2016 Go to the documentation of mojo_sdk 0.2.30 Download mojo_sdk 0.2.30 archive
0.2.29 Jun 13, 2016 Go to the documentation of mojo_sdk 0.2.29 Download mojo_sdk 0.2.29 archive
0.2.28 Jun 2, 2016 Go to the documentation of mojo_sdk 0.2.28 Download mojo_sdk 0.2.28 archive
0.2.27 May 23, 2016 Go to the documentation of mojo_sdk 0.2.27 Download mojo_sdk 0.2.27 archive
0.2.26 May 18, 2016 Go to the documentation of mojo_sdk 0.2.26 Download mojo_sdk 0.2.26 archive
0.2.25 May 13, 2016 Go to the documentation of mojo_sdk 0.2.25 Download mojo_sdk 0.2.25 archive
0.2.24 May 7, 2016 Go to the documentation of mojo_sdk 0.2.24 Download mojo_sdk 0.2.24 archive
0.2.23 Apr 7, 2016 Go to the documentation of mojo_sdk 0.2.23 Download mojo_sdk 0.2.23 archive

All 36 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because mojo_sdk depends on mojo_services >=0.2.0 which requires SDK version <2.0.0, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Package is too old. (-100 points)

The package was released more than two years ago.

Homepage does not exists. (-20 points)

We were unable to access https://github.com/domokit/mojo at the time of the analysis.

Add SDK constraint in pubspec.yaml. (-5 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use mojo_sdk.dart.