This is a MolView module that implements a DataServer. This is basically a module that can connect all other data modules together.
Add this to your package's pubspec.yaml file:
dependencies: molview_dataserver: "^0.2.0+1"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:molview_dataserver/messages_v0.dart'; import 'package:molview_dataserver/module.dart'; import 'package:molview_dataserver/msglib.dart'; import 'package:molview_dataserver/standards.dart';
|0.2.0+1||Oct 17, 2016|
|0.2.0||Sep 7, 2016|
|0.1.0+1||Oct 17, 2016|
|0.1.0||Sep 7, 2016|
|0.0.3||Sep 2, 2016|
|0.0.2||Sep 2, 2016|
We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, web, other
No platform restriction found in libraries.
Changelog entries help clients to follow the progress in your code.
Fix analysis and formatting issues.
Analysis or formatting checks reported 6 errors.
Strong-mode analysis of
lib/src/gen/autocomplete.v0.dartfailed with the following error:
line: 191 col: 11
The argument type '(Map<String, dynamic>) → SearchSuggestion' can't be assigned to the parameter type '(dynamic) → dynamic'.
Strong-mode analysis of
lib/src/gen/dataserver.v0.dartfailed with the following error:
line: 426 col: 15
The argument type '(Map<String, dynamic>) → DataRecord' can't be assigned to the parameter type '(dynamic) → dynamic'.
Similar analysis of the following files failed:
Package is getting outdated.
The package was released 87 weeks ago.
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=1.8.0 <2.0.0|