molview_pubchem 0.3.0+1

  • README.md
  • Installing
  • Versions
  • 0

MolView PubChem module [DEPRICATED]

This module implements data retrieval from the PubChem database using the standard messages from molview_messages.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  molview_pubchem: ^0.3.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:molview_pubchem/molview_pubchem.dart';
  
Version Uploaded Documentation Archive
0.3.0+1 Oct 17, 2016 Go to the documentation of molview_pubchem 0.3.0+1 Download molview_pubchem 0.3.0+1 archive
0.3.0 Sep 7, 2016 Go to the documentation of molview_pubchem 0.3.0 Download molview_pubchem 0.3.0 archive
0.2.0+2 May 30, 2016 Go to the documentation of molview_pubchem 0.2.0+2 Download molview_pubchem 0.2.0+2 archive
0.2.0+1 May 22, 2016 Go to the documentation of molview_pubchem 0.2.0+1 Download molview_pubchem 0.2.0+1 archive
0.2.0 May 9, 2016 Go to the documentation of molview_pubchem 0.2.0 Download molview_pubchem 0.2.0 archive
0.1.3 May 8, 2016 Go to the documentation of molview_pubchem 0.1.3 Download molview_pubchem 0.1.3 archive
0.1.2 Apr 29, 2016 Go to the documentation of molview_pubchem 0.1.2 Download molview_pubchem 0.1.2 archive
0.1.1+1 Apr 20, 2016 Go to the documentation of molview_pubchem 0.1.1+1 Download molview_pubchem 0.1.1+1 archive
0.1.1 Apr 20, 2016 Go to the documentation of molview_pubchem 0.1.1 Download molview_pubchem 0.1.1 archive
0.1.0 Apr 10, 2016 Go to the documentation of molview_pubchem 0.1.0 Download molview_pubchem 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0