This module implements data retrieval from the PubChem database using the
standard messages from
Add this to your package's pubspec.yaml file:
dependencies: molview_pubchem: "^0.3.0+1"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.3.0+1||Oct 17, 2016|
|0.3.0||Sep 7, 2016|
|0.2.0+2||May 30, 2016||failed|
|0.2.0+1||May 22, 2016|
|0.2.0||May 9, 2016|
|0.1.3||May 8, 2016|
|0.1.2||Apr 29, 2016|
|0.1.1+1||Apr 20, 2016|
|0.1.1||Apr 20, 2016|
|0.1.0||Apr 10, 2016|
We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, web, other
No platform restriction found in primary library
Changelog entries help clients to follow the progress in your code.
Fix analysis and formatting issues.
Analysis or formatting checks reported 2 errors 3 hints.
Strong-mode analysis of
lib/src/compounds/module.dartfailed with the following error:
line: 47 col: 39
The argument type '(RetrieveData, State) → Future<DataRetrieved>' can't be assigned to the parameter type '(RetrieveData, dynamic) → Future<OmnibusResponse>'.
Similar analysis of the following files failed:
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=1.8.0 <2.0.0|