molview_wikidata 0.0.2+2

  • README.md
  • Installing
  • Versions
  • 31

MolView Wikidata module [DEPRICATED]

This module integrates Wikidata with MolView using molview_messages.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  molview_wikidata: "^0.0.2+2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:molview_wikidata/molview_wikidata.dart';
  
Version Uploaded Documentation Archive
0.0.2+2 Oct 17, 2016 Go to the documentation of molview_wikidata 0.0.2+2 Download molview_wikidata 0.0.2+2 archive
0.0.2+1 May 30, 2016 Go to the documentation of molview_wikidata 0.0.2+1 Download molview_wikidata 0.0.2+1 archive
0.0.2 May 9, 2016 Go to the documentation of molview_wikidata 0.0.2 Download molview_wikidata 0.0.2 archive
0.0.1 May 9, 2016 Go to the documentation of molview_wikidata 0.0.1 Download molview_wikidata 0.0.1 archive

Analysis

We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
89 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
21 / 100
Overall score:
Weighted score of the above. [more]
31
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:molview_wikidata/molview_wikidata.dart.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error 2 hints.

    Strong-mode analysis of lib/module.dart failed with the following error:

    line: 26 col: 7
    The argument type '(FindSearchSuggestions, SimpleState) → Future<SearchSuggestions>' can't be assigned to the parameter type '(FindSearchSuggestions, dynamic) → Future<OmnibusResponse>'.

    Run dartfmt to format lib/src/autocomplete_compounds.dart.

  • Package is getting outdated.

    The package was released 90 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use molview_wikidata.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
http ^0.11.3+5 0.11.3+17
molview_dataserver ^0.0.3 0.0.3 0.2.0+1
molview_messages ^0.11.0 0.11.0 0.12.0+2
omnibus ^0.15.2 0.15.3+1
Transitive dependencies
async 2.0.7
charcode 1.1.2
collection 1.14.10
http_parser 3.1.2
passive_data 0.7.1+1
path 1.6.1
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
Dev dependencies
omnitest ^0.2.4+2
test ^0.12.7