monads 0.0.1

  • Example
  • Installing
  • Versions
  • 47

A library for Dart developers.

Usage #

See examples

Features and bugs #

1.0.0 #

  • Initial version, created by Stagehand


import 'package:monads/monads.dart';

main() {}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  monads: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:monads/monads.dart';
Version Uploaded Documentation Archive
0.0.1 Dec 4, 2018 Go to the documentation of monads 0.0.1 Download monads 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13+1


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:monads/monads.dart.

Health suggestions

Fix lib/src/result.dart. (-1.49 points)

Analysis of lib/src/result.dart reported 3 hints:

line 1 col 6: Don't explicitly initialize variables to null.

line 17 col 62: Don't explicitly initialize variables to null.

line 17 col 71: Use = to separate a named parameter from its default value.

Fix lib/src/maybe.dart. (-0.50 points)

Analysis of lib/src/maybe.dart reported 1 hint:

line 126 col 12: Avoid types as parameter names.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
Dev dependencies
test ^1.0.0