Add this to your package's pubspec.yaml file:
dependencies: mongo_database: ^1.0.0-dev.0
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.0.0-dev.0||Oct 9, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter, other
README.md. (-30 points)
Readme should inform others about your project, what it does, and how they can use it.
CHANGELOG.md. (-20 points)
Changelog entries help clients to follow the progress in your code.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use
Package is pre-release. (-5 points)
Pre-release versions should be used with caution, their API may change in breaking ways.
|Dart SDK||>=2.0.0 <3.0.0|