monkey2dart 1.0.0-alpha+1

  • Installing
  • Versions
  • 0


Compiles the Monkey programming language into equivalent Dart.

Still missing:

  • IfExpression
  • PrefixExpression
  • print is currently the only available built-in


    monkey2dart: ^1.0.0-alpha

Then, in your command-line:

$ pub get


Requires package:build_runner.

// tool/phases.dart
import 'package:build_runner/build_runner.dart';
import 'package:monkey2dart/build.dart';

final PhaseGroup phases = new PhaseGroup.singleAction(
    const Monkey2DartBuilder(),
    new InputSet('monkey_hello', const ['lib/*.monkey']));

// tool/build.dart
import 'package:build_runner/build_runner.dart';
import 'phases.dart';

main() => build(phases, deleteFilesByDefault: true);
$ dart tool/build.dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  monkey2dart: ^1.0.0-alpha+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:monkey2dart/monkey2dart.dart';
Version Uploaded Documentation Archive
1.0.0-alpha+1 Feb 5, 2017 Go to the documentation of monkey2dart 1.0.0-alpha+1 Download monkey2dart 1.0.0-alpha+1 archive
1.0.0-alpha Feb 5, 2017 Go to the documentation of monkey2dart 1.0.0-alpha Download monkey2dart 1.0.0-alpha archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because monkey2dart depends on build >=0.0.1+1 <=0.12.7 which requires SDK version <2.0.0 or >=2.0.0-dev.9 <2.0.0, version solving failed.

Health suggestions

Format lib/monkey2dart.dart.

Run dartfmt to format lib/monkey2dart.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-85.75 points)

The package was released 96 weeks ago.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution, their API may change in breaking ways.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use monkey2dart.dart. Packages with multiple examples should use example/


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.17.0