monkey_lang 0.9.6

  • README.md
  • Installing
  • Versions
  • 0

Writing an Interpreter for the Monkey 🐒 Language in Dart #

Build Status

A fully working interpreter for the Monkey programming language as known from the book Writing an Interpreter in Go, written in Dart.

Install Monkey and start the REPL #

With one command, you can install the monkey binary:

$ pub global activate monkey_lang
Downloading monkey_lang 0.9.1...
[...]
Installed executable monkey.

Now you can run monkey from anywhere you want!

$ monkey
Hello! This is the Monkey programming language!
Feel free to type in commands
>> let answer = fn(){ 6*7; };
>> answer()
42

Run the test suite #

$ pub run test
[...]
00:00 +42: All tests passed! 

Format + analyze the code #

$ ./dartformat_analyze.sh
Formatting directory lib/:
[...]
Formatting directory test/:
[...]
Analyzing [.]...
No issues found

Go ahead and have fun with Monkey!

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate monkey_lang

2. Use it

The package has the following executables:


$ monkey
Version Uploaded Documentation Archive
0.9.6 Feb 6, 2017 Go to the documentation of monkey_lang 0.9.6 Download monkey_lang 0.9.6 archive
0.9.5 Feb 6, 2017 Go to the documentation of monkey_lang 0.9.5 Download monkey_lang 0.9.5 archive
0.9.4 Feb 5, 2017 Go to the documentation of monkey_lang 0.9.4 Download monkey_lang 0.9.4 archive
0.9.3 Jan 26, 2017 Go to the documentation of monkey_lang 0.9.3 Download monkey_lang 0.9.3 archive
0.9.2 Jan 26, 2017 Go to the documentation of monkey_lang 0.9.2 Download monkey_lang 0.9.2 archive
0.9.1 Jan 25, 2017 Go to the documentation of monkey_lang 0.9.1 Download monkey_lang 0.9.1 archive
0.9.0 Jan 25, 2017 Go to the documentation of monkey_lang 0.9.0 Download monkey_lang 0.9.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.