mrtlib 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

mrtlib

A simple library help to find routes in Taipei MRT.

Created from templates made available by Stagehand under a BSD-style license.

Usage

To the the library, you can create a new instance of MRTMap.

final map = new MRTMap();

Then, you can input two stations and find all possible routes between them.

final routes = map.findRoutes('大安', '忠孝復興');

That's all!

0.0.1

  • Initial version, created by Stagehand

example/mrtlib_example.dart

import 'package:mrtlib/mrtlib.dart';

main() {
  final map = new MRTMap();
  final routes = map.findRoutes('大安', '忠孝復興');
  print('Possible routes between 大安 and 忠孝復興 are including...');
  for (var route in routes) {
    print(route);
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mrtlib: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mrtlib/mrtlib.dart';
  
Version Uploaded Documentation Archive
0.0.1 Jul 1, 2018 Go to the documentation of mrtlib 0.0.1 Download mrtlib 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0