multibtree 0.0.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

multibtree

A library for Dart developers. It is awesome.

Usage

A simple usage example:

import 'package:multibtree/multibtree.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

example/multibtree_example.dart

// Copyright (c) 2017, teja. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:multibtree/multibtree.dart';

main() {
  MultiBTree<int, String> tree = new MultiBTree<int, String>(2);
  tree.insert(1, 'one1');
  tree.insert(2, 'two1');
  tree.insert(1, 'one2');
  tree.insert(3, 'three1');
  tree.insert(1, 'one3');
  tree.insert(1, 'one4');
  print(tree[1]);
  print(tree[2]);
  print(tree[3]);

  tree.remove(1, 'one3');
  print(tree[1]);
  print(tree[2]);
  print(tree[3]);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  multibtree: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:multibtree/multibtree.dart';
  
Version Uploaded Documentation Archive
0.0.3 Feb 12, 2017 Go to the documentation of multibtree 0.0.3 Download multibtree 0.0.3 archive
0.0.2 Feb 12, 2017 Go to the documentation of multibtree 0.0.2 Download multibtree 0.0.2 archive
0.0.1 Feb 11, 2017 Go to the documentation of multibtree 0.0.1 Download multibtree 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0