musicplugin 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

musicplugin

pub package

A plugin for playing music

Getting Started

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  musicplugin: "^0.0.1"

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:musicplugin/musicplugin.dart';

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

[0.0.2] - 25/4/2018

  • Sorting All Songs

[0.0.1] - 20/4/2018

  • just an initial release with basic functionality
  • Fetching All Songs

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  musicplugin: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:musicplugin/musicplugin.dart';
  
Version Uploaded Documentation Archive
0.0.2 Apr 25, 2018 Go to the documentation of musicplugin 0.0.2 Download musicplugin 0.0.2 archive
0.0.1 Apr 19, 2018 Go to the documentation of musicplugin 0.0.1 Download musicplugin 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0