my_complex 0.0.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 44

complex

A library for Dart developers. It is awesome.

Usage

A simple usage example:

import 'package:my_complex/my_complex.dart';

main() {
  var c = new Complex.cartesian(0,2);
  var p = new Complex.polar(2, math.PI/2);
  print(c.equals(p));
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, fast Complex number library!

0.0.2

  • Changed equals functions to catch identity faster

0.0.3

  • Made some fields final
  • Corrected wrong path in README.md

0.0.4

  • Learned how to add documentation so that it appears on the pub
  • renamed "equal" to "similar"

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  my_complex: "^0.0.4"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:my_complex/my_complex.dart';
        
Version Uploaded Documentation Archive
0.0.4 Feb 14, 2017 Go to the documentation of my_complex 0.0.4 Download my_complex 0.0.4 archive
0.0.3 Feb 14, 2017 Go to the documentation of my_complex 0.0.3 Download my_complex 0.0.3 archive
0.0.2 Feb 13, 2017 Go to the documentation of my_complex 0.0.2 Download my_complex 0.0.2 archive
0.0.1 Feb 13, 2017 Go to the documentation of my_complex 0.0.1 Download my_complex 0.0.1 archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
32 / 100
Health:
Code health derived from static analysis. [more]
44 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
75 / 100
Overall score:
Weighted score of the above. [more]
44
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:my_complex/my_complex.dart.

Suggestions

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 11 errors 14 hints.

    Strong-mode analysis of lib/src/complex_cartesian.dart failed with the following error:

    line: 26 col: 3
    Invalid override. The type of 'ComplexCartesian.==' ('(Complex) → bool') isn't a subtype of 'Complex.==' ('(dynamic) → bool').

    Strong-mode analysis of lib/src/complex_constants.dart failed with the following error:

    line: 32 col: 3
    Invalid override. The type of 'ComplexConstant.==' ('(Complex) → bool') isn't a subtype of 'Complex.==' ('(dynamic) → bool').

    Similar analysis of the following files failed:

    • lib/src/complex_polar.dart (error)
    • lib/src/complex_base.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use my_complex.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
Dev dependencies
test >=0.12.0 <0.13.0