myanimelist 0.0.2

  • Installing
  • Versions
  • 0

MyAnimeList API client #

pub package

Provides a wrapper for accessing the MyAnimeList API


  • Initial version with methods for searching. Not yet tested.


  • Update dependencies and models using json_serializable

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  myanimelist: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:myanimelist/myanimelist.dart';
Version Uploaded Documentation Archive
0.0.2 Apr 24, 2018 Go to the documentation of myanimelist 0.0.2 Download myanimelist 0.0.2 archive
0.0.1 Apr 23, 2018 Go to the documentation of myanimelist 0.0.1 Download myanimelist 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.2.0.
 Because myanimelist depends on xml2json >=1.1.0 <3.0.0 which requires SDK version <2.0.0-dev.infinity, version solving failed.

Health suggestions

Format lib/src/models/entry.dart.

Run dartfmt to format lib/src/models/entry.dart.

Format lib/src/models/search_manga_result.dart.

Run dartfmt to format lib/src/models/search_manga_result.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and myanimelist.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-9 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0