Provides a wrapper for accessing the MyAnimeList API
Add this to your package's pubspec.yaml file:
dependencies: myanimelist: "^0.0.2"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.0.2||Apr 24, 2018|
|0.0.1||Apr 23, 2018|
We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, other
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
Fix analysis and formatting issues.
Analysis or formatting checks reported 5 hints.
Strong-mode analysis of
lib/src/mal_client.dartgave the following hint:
line: 34 col: 45
'OK' is deprecated and shouldn't be used.
Similar analysis of the following files failed:
|Dart SDK||>=2.0.0-dev.28.0 <3.0.0|