names_generator 0.1.0

  • Example
  • Installing
  • Versions
  • 0

names_generator #

Docker's namesgenerator in Dart.

getRandomName generates a random name from the list of adjectives and surnames in this package formatted as "adjective_surname". For example 'focused_turing'. If retry is non-zero, a random integer between 0 and 10 will be added to the end of the name, e.g focused_turing3

Examples #

import 'package:names_generator/names_generator.dart';

main() {
  final name = getRandomName(1);
  print(name); // backstabbing_snyder9

Changelog #

0.1.0 #

  • Initial version


// Copyright (c) 2016, Kwang Yul Seo. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:names_generator/names_generator.dart';

main() {
  final name = getRandomName(1);
  print(name); // backstabbing_snyder9

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  names_generator: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:names_generator/names_generator.dart';
Version Uploaded Documentation Archive
0.1.0 Sep 30, 2016 Go to the documentation of names_generator 0.1.0 Download names_generator 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0