native_alert_dialog_plugin 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 67

pub package

native_alert_dialog_plugin

Basic plugin to create native alert dialog

import 'package:native_alert_dialog_plugin/native_alert_dialog_plugin.dart';

//return user selection true for positive else false
Future<bool> showNativeDialog({
  String title, 
  String body,
  String positiveButtonText,
  String negativeButtonText,
  Color buttonColor,
})

0.0.1

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:native_alert_dialog_plugin/native_alert_dialog_plugin.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {
  bool _userAnswer = false;
  String _title = 'Native Alert Dialog';
  String _body = 'Do you want to proceed?';
  String _positiveButtonText = 'OK';
  String _negativeButtonText = 'CANCEL';

  void _showNativeDialog() {
    showNativeDialog(
            title: _title,
            body: _body,
            positiveButtonText: _positiveButtonText,
            negativeButtonText: _negativeButtonText,
            buttonColor: Theme.of(context).primaryColor)
        .then((answer) => setState(() {
              _userAnswer = answer;
            }));
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text('Plugin example app'),
        ),
        body: new Center(
          child: ListView(
            children: <Widget>[
              TextFormField(
                decoration: InputDecoration(
                  labelText: 'Title',
                  hintText: _title,
                ),
                onSaved: (title) => _title = title,
              ),
              TextFormField(
                decoration: InputDecoration(
                  labelText: 'Body',
                  hintText: _body,
                ),
                onSaved: (body) => _body = body,
              ),
              TextFormField(
                decoration: InputDecoration(
                  labelText: 'Positive Button Text',
                  hintText: _positiveButtonText,
                ),
                onSaved: (positiveButtonText) =>
                    _positiveButtonText = positiveButtonText,
              ),
              TextFormField(
                decoration: InputDecoration(
                  labelText: 'Negative Button Text',
                  hintText: _negativeButtonText,
                ),
                onSaved: (negativeButtonText) =>
                    _negativeButtonText = negativeButtonText,
              ),
              Text('Result = $_userAnswer'),
              RaisedButton(
                onPressed: _showNativeDialog,
                child: Text("show dialog"),
              )
            ],
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  native_alert_dialog_plugin: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:native_alert_dialog_plugin/native_alert_dialog_plugin.dart';
  
Version Uploaded Documentation Archive
0.0.1 Aug 29, 2018 Go to the documentation of native_alert_dialog_plugin 0.0.1 Download native_alert_dialog_plugin 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Oct 26, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0-dev.7.1.flutter-b99bcfd309
  • pana: 0.12.5
  • Flutter: 0.10.1

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8