native_extension_template 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

Boilerplate for Dart native extension projects

This repository serves a boilerplate for cross-platform native extension development for Dart.

Advantages

  • Support for cross-platform
    • Linux
    • Windows
    • MacOS
  • Write native code using Eclipse IDE
  • Boilerplate code to get started

Todo

Features

  • [ ] Support MacOS

Docs

Linux

  • [ ] Installing build tools
  • [ ] Setting up eclipse
  • [ ] Copying the shared library

Windows

  • [ ] Installing build tools
  • [ ] Setting up eclipse
  • [ ] Copying the shared library

MacOS

  • [ ] Installing build tools
  • [ ] Setting up eclipse
  • [ ] Copying the shared library

Changelog

0.0.2

  • Windows support

0.0.1

  • Linux support

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  native_extension_template: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:native_extension_template/native_extension_template.dart';
  
Version Uploaded Documentation Archive
0.0.2 Dec 8, 2017 Go to the documentation of native_extension_template 0.0.2 Download native_extension_template 0.0.2 archive
0.0.1 Dec 3, 2017 Go to the documentation of native_extension_template 0.0.1 Download native_extension_template 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Health suggestions

Format lib/native_extension_template.dart.

Run dartfmt to format lib/native_extension_template.dart.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Use analysis_options.yaml. (-10 points)

Rename old .analysis_options file to analysis_options.yaml.

Read more about the setup of analysis-options.yaml.

Fix .analysis_options.

We were unable to parse .analysis_options.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use native_extension_template.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.